summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons/qtcharts_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5-addons/qtcharts_2.0.bb')
-rw-r--r--recipes-qt/qt5-addons/qtcharts_2.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qt/qt5-addons/qtcharts_2.0.bb b/recipes-qt/qt5-addons/qtcharts_2.0.bb
new file mode 100644
index 0000000..4b350de
--- /dev/null
+++ b/recipes-qt/qt5-addons/qtcharts_2.0.bb
@@ -0,0 +1,47 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Qt Charts"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://src/charts/qchart.cpp;md5=735b3be820c0a733e328a4d2e1e430de;beginline=1;endline=17"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.it.local/QtRD-15810/charts.git;branch=${QT_BRANCH};protocol=ssh \
31 "
32
33SRCREV = "f818972d3617493c74d694184aa877f606e1a5a0"
34QT_BRANCH = "master"
35
36S = "${WORKDIR}/git"
37
38DEPENDS = "qtbase qtdeclarative qtmultimedia"
39
40PACKAGES =+ "${PN}-designer"
41DEBIAN_NOAUTONAME_${PN}-designer = "1"
42
43FILES_${PN}-designer = " \
44 ${OE_QMAKE_PATH_QML}/QtCharts/designer \
45 "
46
47RRECOMMENDS_${PN}-dev += "${PN}-designer"