diff options
Diffstat (limited to 'recipes-qt/qt5-addons/qtquickcompiler-sdk.bb')
-rw-r--r-- | recipes-qt/qt5-addons/qtquickcompiler-sdk.bb | 78 |
1 files changed, 0 insertions, 78 deletions
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb deleted file mode 100644 index b21b2ce..0000000 --- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb +++ /dev/null | |||
@@ -1,78 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Qt Quick Compiler using prebuilt binaries from Qt SDK" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
33 | |||
34 | inherit allarch qmake5_paths | ||
35 | |||
36 | SRC_URI = "http://download.qt.io/development_releases/prebuilt/mingw_32/i686-4.9.2-release-posix-dwarf-rt_v3-rev1-runtime.7z" | ||
37 | |||
38 | SRC_URI[md5sum] = "a7d673c4ad8bcef9e464ea5386492cb3" | ||
39 | SRC_URI[sha256sum] = "f7e58b0fb1f5aa4c23eefdc60abb88cb642eaa272fb741dca23068c70ca86542" | ||
40 | |||
41 | S = "${WORKDIR}" | ||
42 | |||
43 | NATIVESDK_BINARY = "qtquickcompiler" | ||
44 | NATIVESDK_BINARY_mingw32 = "qtquickcompiler.exe" | ||
45 | |||
46 | do_install() { | ||
47 | install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features | ||
48 | install -m 0755 ${THISDIR}/qtquickcompiler-sdk/mkspecs/features/qtquickcompiler.prf ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features | ||
49 | install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler | ||
50 | install -m 0644 ${THISDIR}/qtquickcompiler-sdk/lib/cmake/Qt5QuickCompiler/Qt5QuickCompilerConfig.cmake ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler | ||
51 | |||
52 | if [ "${PN}" = "qtquickcompiler-sdk-native" ]; then | ||
53 | install -d ${D}${OE_QMAKE_PATH_BINS} | ||
54 | install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/qtquickcompiler ${D}${OE_QMAKE_PATH_BINS} | ||
55 | elif [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then | ||
56 | install -d ${D}${OE_QMAKE_PATH_BINS} | ||
57 | install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/${NATIVESDK_BINARY} ${D}${OE_QMAKE_PATH_BINS} | ||
58 | fi | ||
59 | |||
60 | # Use the EffectivePath instead of installation path | ||
61 | sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf | ||
62 | } | ||
63 | |||
64 | do_install_append_mingw32() { | ||
65 | if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then | ||
66 | install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS} | ||
67 | install -m 0644 ${WORKDIR}/libwinpthread-1.dll ${D}${OE_QMAKE_PATH_BINS} | ||
68 | fi | ||
69 | } | ||
70 | |||
71 | INHIBIT_PACKAGE_STRIP = "1" | ||
72 | ALLOW_EMPTY_${PN} = "1" | ||
73 | PACKAGES =+ "${PN}-tools" | ||
74 | FILES_${PN}-tools = "${OE_QMAKE_PATH_BINS}" | ||
75 | FILES_${PN}-dev = "${OE_QMAKE_PATH_ARCHDATA}" | ||
76 | INSANE_SKIP_${PN} += "already-stripped" | ||
77 | |||
78 | BBCLASSEXTEND = "native nativesdk" | ||