summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5-addons')
-rw-r--r--recipes-qt/qt5-addons/installer-framework_3.0.1.bb50
-rw-r--r--recipes-qt/qt5-addons/qtglesstream.bb65
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler-sdk.bb78
-rw-r--r--recipes-qt/qt5-addons/qtsimulator_1.0.bb45
4 files changed, 0 insertions, 238 deletions
diff --git a/recipes-qt/qt5-addons/installer-framework_3.0.1.bb b/recipes-qt/qt5-addons/installer-framework_3.0.1.bb
deleted file mode 100644
index 5bc09c0..0000000
--- a/recipes-qt/qt5-addons/installer-framework_3.0.1.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Installer Framework"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit bin_package native
35
36do_unpack[depends] += "p7zip-native:do_populate_sysroot"
37
38SRC_URI = "http://download.qt.io/development_releases/installer-framework/${PV}/installer-framework-build-stripped-${PV}-linux-x64.7z"
39
40SRC_URI[md5sum] = "68b7c1f761ca0dba18f1d165d66005d6"
41SRC_URI[sha256sum] = "c2eb769351025e0c7df2882116390fffaf958368f873a2abab99e37caee0a498"
42
43S = "${WORKDIR}/ifw-pkg"
44
45do_install() {
46 install -d ${D}${bindir}
47 install -m 0755 -t ${D}${bindir} ${S}/bin/*
48}
49
50INSANE_SKIP_${PN} += "already-stripped"
diff --git a/recipes-qt/qt5-addons/qtglesstream.bb b/recipes-qt/qt5-addons/qtglesstream.bb
deleted file mode 100644
index bbf3d00..0000000
--- a/recipes-qt/qt5-addons/qtglesstream.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QtGlesStream"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://qtglesstream.pro;md5=e95d9351d26ed899188e02d44133cae0"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/qt/tqtc-qtglesstream;branch=${BRANCH};protocol=ssh \
38 "
39
40PV = "1.0.0"
41SRCREV = "114e5a1941f831d082395ed80a017f45d3b71a63"
42BRANCH = "dev"
43
44S = "${WORKDIR}/git"
45
46DEPENDS = "qtbase"
47RREPLACES_${PN} = "qtglesstream-dummy-client"
48RREPLACES_${PN}-dev = "qtglesstream-dummy-client-dev"
49
50do_install_append() {
51 install -m 0755 -d ${D}${includedir}/EGL
52 install -m 0755 ${S}/headers/EGL/* ${D}${includedir}/EGL
53
54 install -m 0755 -d ${D}${includedir}/GLES2
55 install -m 0755 ${S}/headers/GLES2/* ${D}${includedir}/GLES2
56
57 install -m 0755 -d ${D}${includedir}/GLES3
58 install -m 0755 ${S}/headers/GLES3/* ${D}${includedir}/GLES3
59
60 install -m 0755 -d ${D}${includedir}/KHR
61 install -m 0755 ${S}/headers/KHR/* ${D}${includedir}/KHR
62}
63
64# no not overwrite files from qtglesstream-dummy-client
65do_populate_sysroot[noexec] = "1"
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
deleted file mode 100644
index b21b2ce..0000000
--- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
+++ /dev/null
@@ -1,78 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Quick Compiler using prebuilt binaries from Qt SDK"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit allarch qmake5_paths
35
36SRC_URI = "http://download.qt.io/development_releases/prebuilt/mingw_32/i686-4.9.2-release-posix-dwarf-rt_v3-rev1-runtime.7z"
37
38SRC_URI[md5sum] = "a7d673c4ad8bcef9e464ea5386492cb3"
39SRC_URI[sha256sum] = "f7e58b0fb1f5aa4c23eefdc60abb88cb642eaa272fb741dca23068c70ca86542"
40
41S = "${WORKDIR}"
42
43NATIVESDK_BINARY = "qtquickcompiler"
44NATIVESDK_BINARY_mingw32 = "qtquickcompiler.exe"
45
46do_install() {
47 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
48 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/mkspecs/features/qtquickcompiler.prf ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features
49 install -d ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
50 install -m 0644 ${THISDIR}/qtquickcompiler-sdk/lib/cmake/Qt5QuickCompiler/Qt5QuickCompilerConfig.cmake ${D}${OE_QMAKE_PATH_ARCHDATA}/cmake/Qt5QuickCompiler
51
52 if [ "${PN}" = "qtquickcompiler-sdk-native" ]; then
53 install -d ${D}${OE_QMAKE_PATH_BINS}
54 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/qtquickcompiler ${D}${OE_QMAKE_PATH_BINS}
55 elif [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
56 install -d ${D}${OE_QMAKE_PATH_BINS}
57 install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/${NATIVESDK_BINARY} ${D}${OE_QMAKE_PATH_BINS}
58 fi
59
60 # Use the EffectivePath instead of installation path
61 sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
62}
63
64do_install_append_mingw32() {
65 if [ "${PN}" = "nativesdk-qtquickcompiler-sdk" ]; then
66 install -m 0644 ${WORKDIR}/libgcc_s_dw2-1.dll ${D}${OE_QMAKE_PATH_BINS}
67 install -m 0644 ${WORKDIR}/libwinpthread-1.dll ${D}${OE_QMAKE_PATH_BINS}
68 fi
69}
70
71INHIBIT_PACKAGE_STRIP = "1"
72ALLOW_EMPTY_${PN} = "1"
73PACKAGES =+ "${PN}-tools"
74FILES_${PN}-tools = "${OE_QMAKE_PATH_BINS}"
75FILES_${PN}-dev = "${OE_QMAKE_PATH_ARCHDATA}"
76INSANE_SKIP_${PN} += "already-stripped"
77
78BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5-addons/qtsimulator_1.0.bb b/recipes-qt/qt5-addons/qtsimulator_1.0.bb
deleted file mode 100644
index 4d46679..0000000
--- a/recipes-qt/qt5-addons/qtsimulator_1.0.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QtSimulator"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://src/simulator/version.h;md5=eb588a9fa3a2a45f725e9eb9f864e74b;beginline=1;endline=17"
33
34inherit qt5-module
35
36SRC_URI = " \
37 git://codereview.qt-project.org/tqtc-boot2qt/qtsimulator;branch=${BRANCH};protocol=ssh \
38 "
39
40SRCREV = "0307e85a8d3a8b83a346aa3910e88aabb7b7b2ac"
41BRANCH = "master"
42
43S = "${WORKDIR}/git"
44
45DEPENDS = "qtbase"