summaryrefslogtreecommitdiffstats
path: root/recipes/adbd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/adbd')
-rw-r--r--recipes/adbd/adbd.bb22
-rwxr-xr-xrecipes/adbd/files/adb-init2
-rw-r--r--recipes/adbd/files/raspberrypi/adb-init21
3 files changed, 44 insertions, 1 deletions
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index aa8f5e9..1feb7c3 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -1,3 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
1DESCRIPTION = "Android Debug Bridge Daemon" 23DESCRIPTION = "Android Debug Bridge Daemon"
2HOMEPAGE = "http://developer.android.com/tools/help/adb.html" 24HOMEPAGE = "http://developer.android.com/tools/help/adb.html"
3SECTION = "devel" 25SECTION = "devel"
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init
index e88df23..6faed60 100755
--- a/recipes/adbd/files/adb-init
+++ b/recipes/adbd/files/adb-init
@@ -8,7 +8,7 @@ SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
8 8
9case "$1" in 9case "$1" in
10start) 10start)
11 insmod $(busybox find /lib/modules/$(uname -r) -name "g_ffs.ko") idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL} 11 modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL}
12 mkdir -p /dev/usb-ffs 12 mkdir -p /dev/usb-ffs
13 chmod 770 /dev/usb-ffs 13 chmod 770 /dev/usb-ffs
14 mkdir -p /dev/usb-ffs/adb 14 mkdir -p /dev/usb-ffs/adb
diff --git a/recipes/adbd/files/raspberrypi/adb-init b/recipes/adbd/files/raspberrypi/adb-init
new file mode 100644
index 0000000..8910e0e
--- /dev/null
+++ b/recipes/adbd/files/raspberrypi/adb-init
@@ -0,0 +1,21 @@
1#!/bin/sh
2
3DAEMON=/usr/bin/adbd
4
5case "$1" in
6start)
7 start-stop-daemon --start --quiet --exec $DAEMON &
8 ;;
9stop)
10 start-stop-daemon --stop --quiet --exec $DAEMON
11 ;;
12restart)
13 start-stop-daemon --stop --quiet --exec $DAEMON
14 sleep 1
15 start-stop-daemon --start --quiet --exec $DAEMON &
16 ;;
17*)
18 echo "Usage: $0 {start|stop|restart}"
19 exit 1
20esac
21exit 0