summaryrefslogtreecommitdiffstats
path: root/recipes/b2qt-update-framework/b2qt-update-framework.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/b2qt-update-framework/b2qt-update-framework.bb')
-rw-r--r--recipes/b2qt-update-framework/b2qt-update-framework.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes/b2qt-update-framework/b2qt-update-framework.bb b/recipes/b2qt-update-framework/b2qt-update-framework.bb
deleted file mode 100644
index ceae95a..0000000
--- a/recipes/b2qt-update-framework/b2qt-update-framework.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Boot to Qt update framework"
24HOMEPAGE = "http://www.qt.io"
25SECTION = "devel"
26LICENSE = "CLOSED"
27
28PV = "1.0.0"
29PR = "r0"
30SRCREV = "${PV}"
31
32inherit deploy
33
34do_deploy() {
35 install -d ${DEPLOYDIR}/update/
36 echo ${B2QT_PLATFORM} > ${DEPLOYDIR}/update/platform
37}
38
39addtask deploy after do_install before do_build
40
41do_compile[noexec] = "1"
42do_install[noexec] = "1"
43do_populate_sysroot[noexec] = "1"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"