summaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.22.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.22.1.bbappend')
-rw-r--r--recipes/busybox/busybox_1.22.1.bbappend46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.22.1.bbappend b/recipes/busybox/busybox_1.22.1.bbappend
new file mode 100644
index 0000000..fe5d5ea
--- /dev/null
+++ b/recipes/busybox/busybox_1.22.1.bbappend
@@ -0,0 +1,46 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "\
25 file://network.cfg \
26 file://busybox-ifplugd.sh \
27 file://ifplugd.action \
28 "
29
30PACKAGES =+ "${PN}-ifplugd"
31FILES_${PN}-ifplugd = "\
32 ${sysconfdir}/init.d/busybox-ifplugd.sh \
33 ${sysconfdir}/etc/ifplugd/ifplugd.action \
34 "
35
36INITSCRIPT_PACKAGES += "${PN}-ifplugd"
37INITSCRIPT_NAME_${PN}-ifplugd = "busybox-ifplugd.sh"
38
39RRECOMMENDS_${PN} += "${PN}-ifplugd"
40
41do_install_append () {
42 install -m 0755 ${WORKDIR}/busybox-ifplugd.sh ${D}${sysconfdir}/init.d/
43
44 install -d ${D}${sysconfdir}/ifplugd
45 install -m 0755 ${WORKDIR}/ifplugd.action ${D}${sysconfdir}/ifplugd/
46}