summaryrefslogtreecommitdiffstats
path: root/recipes/fonts/ttf-opensans.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fonts/ttf-opensans.bb')
-rw-r--r--recipes/fonts/ttf-opensans.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
new file mode 100644
index 0000000..ad40b81
--- /dev/null
+++ b/recipes/fonts/ttf-opensans.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Open Sans Fonts"
2SECTION = "fonts"
3HOMEPAGE = "https://www.google.com/fonts"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9inherit allarch fontcache
10
11SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip"
12# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check
13BB_STRICT_CHECKSUM = ""
14
15do_install() {
16 install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans
17 install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans
18}
19
20PACKAGES = "${PN}"
21FILES_${PN} += "${datadir}/fonts/truetype/opensans"