diff options
Diffstat (limited to 'recipes/fonts/ttf-opensans.bb')
-rw-r--r-- | recipes/fonts/ttf-opensans.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb new file mode 100644 index 0000000..ad40b81 --- /dev/null +++ b/recipes/fonts/ttf-opensans.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Open Sans Fonts" | ||
2 | SECTION = "fonts" | ||
3 | HOMEPAGE = "https://www.google.com/fonts" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | inherit allarch fontcache | ||
10 | |||
11 | SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip" | ||
12 | # Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check | ||
13 | BB_STRICT_CHECKSUM = "" | ||
14 | |||
15 | do_install() { | ||
16 | install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans | ||
17 | install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans | ||
18 | } | ||
19 | |||
20 | PACKAGES = "${PN}" | ||
21 | FILES_${PN} += "${datadir}/fonts/truetype/opensans" | ||