summaryrefslogtreecommitdiffstats
path: root/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gdb/gdb-cross-canadian_7.5.1.bbappend')
-rw-r--r--recipes/gdb/gdb-cross-canadian_7.5.1.bbappend35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend b/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend
deleted file mode 100644
index f96bc35..0000000
--- a/recipes/gdb/gdb-cross-canadian_7.5.1.bbappend
+++ /dev/null
@@ -1,35 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_compile_prepend() {
24cat > ${WORKDIR}/python << EOF
25#! /bin/sh
26case "\$2" in
27 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
28 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
29 --exec-prefix) echo "${exec_prefix}" ;;
30 *) exit 1 ;;
31esac
32exit 0
33EOF
34 chmod +x ${WORKDIR}/python
35}