summaryrefslogtreecommitdiffstats
path: root/recipes/hunspell/hunspell_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hunspell/hunspell_1.3.2.bb')
-rw-r--r--recipes/hunspell/hunspell_1.3.2.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/hunspell/hunspell_1.3.2.bb b/recipes/hunspell/hunspell_1.3.2.bb
new file mode 100644
index 0000000..beb071d
--- /dev/null
+++ b/recipes/hunspell/hunspell_1.3.2.bb
@@ -0,0 +1,55 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Hunspell"
24LICENSE = "LGPLv2"
25LIC_FILES_CHKSUM = "file://${WORKDIR}/hunspell-${PV}/COPYING;md5=ed3a37b3ba6d6be3e08ab45987cf1b88"
26
27SRC_URI = "http://downloads.sourceforge.net/hunspell/hunspell-${PV}.tar.gz;name=hunspell \
28 http://ftp.halifax.rwth-aachen.de/gentoo/distfiles/myspell-en_GB-20081002.zip;name=dict-en \
29 http://downloads.sourceforge.net/project/ayaspell/hunspell-ar/20080110/hunspell-ar_20080110.tar.gz;name=dict-ar \
30 "
31
32SRC_URI[hunspell.md5sum] = "3121aaf3e13e5d88dfff13fb4a5f1ab8"
33SRC_URI[hunspell.sha256sum] = "b4edd4a4ee944cb9f485b35473e46b729ed768e9d24da8e78e4c4c6ca56addbd"
34SRC_URI[dict-en.md5sum] = "6fb885d57899c3e6aa2b27f3510deb37"
35SRC_URI[dict-en.sha256sum] = "f4b43083923e2998298fd270a8a9f9ed570f4fbebeaa46ce5f1788b76920308b"
36SRC_URI[dict-ar.md5sum] = "69990932920960eb765fd35883640124"
37SRC_URI[dict-ar.sha256sum] = "88d9eebbe05de29d17f4420ebaec9249441ce01d61b5d6c7ecba040e250e2d91"
38
39PR = "r0"
40
41inherit autotools gettext
42
43PACKAGES += "${PN}-dicts"
44RRECOMMENDS_${PN} += "${PN}-dicts"
45FILES_${PN}-dicts = "${datadir}/hunspell"
46
47do_install_append() {
48 install -m 0755 -d ${D}${datadir}/hunspell
49
50 install -m 0755 ${WORKDIR}/hunspell-ar_20080110/ar.dic ${D}${datadir}/hunspell/ar_EG.dic
51 install -m 0755 ${WORKDIR}/hunspell-ar_20080110/ar.aff ${D}${datadir}/hunspell/ar_EG.aff
52
53 install -m 0755 ${WORKDIR}/en_GB.dic ${D}${datadir}/hunspell
54 install -m 0755 ${WORKDIR}/en_GB.aff ${D}${datadir}/hunspell
55}