diff options
Diffstat (limited to 'recipes/initramfs-basic/init-basic.bb')
-rw-r--r-- | recipes/initramfs-basic/init-basic.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/initramfs-basic/init-basic.bb b/recipes/initramfs-basic/init-basic.bb new file mode 100644 index 0000000..674e683 --- /dev/null +++ b/recipes/initramfs-basic/init-basic.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | SUMMARY = "Simple init script that mounts root filesystem by label." | ||
23 | LICENSE = "CLOSED" | ||
24 | SRC_URI = "file://init.sh" | ||
25 | |||
26 | S = "${WORKDIR}" | ||
27 | |||
28 | do_install () { | ||
29 | install -m 0755 ${WORKDIR}/init.sh ${D}/init | ||
30 | } | ||
31 | |||
32 | inherit allarch | ||
33 | |||
34 | FILES_${PN} += "/init" | ||