diff options
Diffstat (limited to 'recipes/initramfs-basic/initramfs-basic.bb')
-rw-r--r-- | recipes/initramfs-basic/initramfs-basic.bb | 50 |
1 files changed, 0 insertions, 50 deletions
diff --git a/recipes/initramfs-basic/initramfs-basic.bb b/recipes/initramfs-basic/initramfs-basic.bb deleted file mode 100644 index 31388d3..0000000 --- a/recipes/initramfs-basic/initramfs-basic.bb +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "Basic initramfs image. Useful as a template for more advanced functionality." | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | ||
33 | |||
34 | # findfs from busybox fails to do its jobs, the full version from util-linux-findfs works fine | ||
35 | PACKAGE_INSTALL = "init-basic busybox util-linux-findfs ${ROOTFS_BOOTSTRAP_INSTALL}" | ||
36 | |||
37 | # Do not pollute the initramfs image with rootfs features | ||
38 | IMAGE_FEATURES = "" | ||
39 | |||
40 | export IMAGE_BASENAME = "initramfs-basic" | ||
41 | IMAGE_LINGUAS = "" | ||
42 | |||
43 | IMAGE_FSTYPES = "cpio.gz" | ||
44 | inherit core-image | ||
45 | |||
46 | IMAGE_ROOTFS_SIZE = "8192" | ||
47 | IMAGE_ROOTFS_EXTRA_SPACE = "0" | ||
48 | |||
49 | BAD_RECOMMENDATIONS += "busybox-syslog" | ||
50 | |||