diff options
Diffstat (limited to 'recipes/initramfs-basic/initramfs-basic.bb')
-rw-r--r-- | recipes/initramfs-basic/initramfs-basic.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/initramfs-basic/initramfs-basic.bb b/recipes/initramfs-basic/initramfs-basic.bb new file mode 100644 index 0000000..4bef9c8 --- /dev/null +++ b/recipes/initramfs-basic/initramfs-basic.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Basic initramfs image. Useful as a template for more advanced functionality." | ||
23 | LICENSE = "CLOSED" | ||
24 | |||
25 | # findfs from busybox fails to do its jobs, the full version from util-linux-findfs works fine | ||
26 | PACKAGE_INSTALL = "init-basic busybox util-linux-findfs ${ROOTFS_BOOTSTRAP_INSTALL}" | ||
27 | |||
28 | # Do not pollute the initramfs image with rootfs features | ||
29 | IMAGE_FEATURES = "" | ||
30 | |||
31 | export IMAGE_BASENAME = "initramfs-basic" | ||
32 | IMAGE_LINGUAS = "" | ||
33 | |||
34 | IMAGE_FSTYPES = "cpio.gz" | ||
35 | inherit core-image | ||
36 | |||
37 | IMAGE_ROOTFS_SIZE = "8192" | ||
38 | |||
39 | BAD_RECOMMENDATIONS += "busybox-syslog" | ||
40 | |||