summaryrefslogtreecommitdiffstats
path: root/recipes/libgles/libgles-omap3_5.00.00.01.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgles/libgles-omap3_5.00.00.01.bbappend')
-rw-r--r--recipes/libgles/libgles-omap3_5.00.00.01.bbappend46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/libgles/libgles-omap3_5.00.00.01.bbappend b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend
new file mode 100644
index 0000000..5446ffa
--- /dev/null
+++ b/recipes/libgles/libgles-omap3_5.00.00.01.bbappend
@@ -0,0 +1,46 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
26BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x"
27
28LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
29
30do_install_append() {
31 echo "ParamBufferSize=33554432" >> ${D}${sysconfdir}/powervr.ini
32}
33
34# Inhibit warnings about files being stripped.
35INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
36
37pkg_postinst_${PN}_append() {
38ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
39echo ${ESREV} > $D${sysconfdir}/powervr-esrev
40}
41
42RRECOMMENDS_${PN} = "omap3-sgx-modules"
43RRECOMMENDS_${PN}-blitwsegl = ""
44RRECOMMENDS_${PN}-flipwsegl = ""
45RRECOMMENDS_${PN}-frontwsegl = ""
46RRECOMMENDS_${PN}-linuxfbwsegl = ""