summaryrefslogtreecommitdiffstats
path: root/recipes/libgsystem/libgsystem.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgsystem/libgsystem.bb')
-rw-r--r--recipes/libgsystem/libgsystem.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/libgsystem/libgsystem.bb b/recipes/libgsystem/libgsystem.bb
new file mode 100644
index 0000000..d2d1a0b
--- /dev/null
+++ b/recipes/libgsystem/libgsystem.bb
@@ -0,0 +1,41 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23SUMMARY = "LibGSystem is a GIO-based library, targeted primarily for use by operating system components."
24
25LICENSE = "LGPL-2.1"
26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
27
28inherit autotools pkgconfig
29
30SRC_URI = "gitsm://github.com/GNOME/libgsystem.git;tag=v2015.2;protocol=git"
31S = "${WORKDIR}/git"
32
33DEPENDS = "glib-2.0 attr libcap"
34
35do_configure_prepend() {
36 # Workaround a broken configure.ac. It should check first if GTK_DOC_CHECK
37 # macro is actually defined before trying to use it. For how-to see:
38 # https://developer.gnome.org/gtk-doc-manual/stable/settingup_autoconf.html.en
39 # We get a syntax error since we do not bundle gnome recipes that define this macro.
40 sed -i '/GTK_DOC_CHECK/d' ${S}/configure.ac
41}