diff options
Diffstat (limited to 'recipes/llvm/llvm3.2_3.2.bb')
-rw-r--r-- | recipes/llvm/llvm3.2_3.2.bb | 127 |
1 files changed, 0 insertions, 127 deletions
diff --git a/recipes/llvm/llvm3.2_3.2.bb b/recipes/llvm/llvm3.2_3.2.bb deleted file mode 100644 index 92b62f9..0000000 --- a/recipes/llvm/llvm3.2_3.2.bb +++ /dev/null | |||
@@ -1,127 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "The Low Level Virtual Machine" | ||
24 | HOMEPAGE = "http://llvm.org" | ||
25 | # 3-clause BSD-like | ||
26 | LICENSE = "NCSA" | ||
27 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=60fdd7739841f04a2ce2171a726be8f3" | ||
28 | |||
29 | DEPENDS = "libffi libxml2-native llvm-common" | ||
30 | |||
31 | SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz" | ||
32 | SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch " | ||
33 | |||
34 | SRC_URI[md5sum] = "71610289bbc819e3e15fdd562809a2d7" | ||
35 | SRC_URI[sha256sum] = "125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343" | ||
36 | |||
37 | S = "${WORKDIR}/llvm-${PV}.src" | ||
38 | |||
39 | inherit autotools perlnative pythonnative | ||
40 | |||
41 | LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build" | ||
42 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" | ||
43 | LLVM_DIR = "llvm${PV}" | ||
44 | |||
45 | EXTRA_OECONF += "--disable-assertions \ | ||
46 | --enable-debug-runtime \ | ||
47 | --disable-expensive-checks \ | ||
48 | --enable-bindings=none \ | ||
49 | --enable-keep-symbols \ | ||
50 | --enable-libffi \ | ||
51 | --enable-optimized \ | ||
52 | --enable-shared \ | ||
53 | --enable-targets=host-only" | ||
54 | EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1" | ||
55 | FILES_${PN} = "${libdir}/lib*.so \ | ||
56 | ${libdir}/${LLVM_DIR}/*" | ||
57 | FILES_${PN}-dbg = "${bindir}/${LLVM_DIR}/.debug \ | ||
58 | ${libdir}/${LLVM_DIR}/.debug \ | ||
59 | ${libdir}/.debug \ | ||
60 | /usr/src/debug" | ||
61 | FILES_${PN}-dev = "${bindir}/${LLVM_DIR} \ | ||
62 | ${includedir}/${LLVM_DIR} \ | ||
63 | ${libdir}/${LLVM_DIR}/BugpointPasses.so \ | ||
64 | ${libdir}/${LLVM_DIR}/LLVMHello.so" | ||
65 | FILES_${PN}-static-dev = "${libdir}/${LLVM_DIR}/*.a" | ||
66 | FILES_SOLIBSDEV = "" | ||
67 | INSANE_SKIP_${PN} = "dev-so" | ||
68 | |||
69 | do_configure_prepend() { | ||
70 | # Remove RPATHs | ||
71 | sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules | ||
72 | |||
73 | # Drop "svn" suffix from version string | ||
74 | sed -i 's/3\.2svn/3.2/g' configure | ||
75 | |||
76 | # Fix paths in llvm-config | ||
77 | sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp | ||
78 | sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp | ||
79 | |||
80 | # Fails to build unless using separate directory from source | ||
81 | mkdir -p ${LLVM_BUILD_DIR} | ||
82 | cd ${LLVM_BUILD_DIR} | ||
83 | } | ||
84 | |||
85 | do_compile() { | ||
86 | cd ${LLVM_BUILD_DIR} | ||
87 | oe_runmake \ | ||
88 | AR="${BUILD_AR}" \ | ||
89 | CC="${BUILD_CC}" \ | ||
90 | CFLAGS="${BUILD_CFLAGS}" \ | ||
91 | CXX="${BUILD_CXX}" \ | ||
92 | CXXFLAGS="${BUILD_CXXFLAGS}" \ | ||
93 | CPP="${BUILD_CPP}" \ | ||
94 | CPPFLAGS="${BUILD_CPPFLAGS}" \ | ||
95 | NM="${BUILD_NM}" \ | ||
96 | RANLIB="${BUILD_RANLIB}" \ | ||
97 | PATH="${STAGING_BINDIR_NATIVE}:$PATH" \ | ||
98 | cross-compile-build-tools | ||
99 | oe_runmake | ||
100 | } | ||
101 | |||
102 | do_install() { | ||
103 | cd ${LLVM_BUILD_DIR} | ||
104 | oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install | ||
105 | |||
106 | mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host | ||
107 | |||
108 | install -d ${D}${bindir}/${LLVM_DIR} | ||
109 | mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/ | ||
110 | |||
111 | install -d ${D}${includedir}/${LLVM_DIR} | ||
112 | mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/ | ||
113 | |||
114 | install -d ${D}${libdir}/${LLVM_DIR} | ||
115 | mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/ | ||
116 | ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so | ||
117 | |||
118 | install -d ${D}${docdir}/${LLVM_DIR} | ||
119 | mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR} | ||
120 | } | ||
121 | |||
122 | SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess" | ||
123 | |||
124 | llvm_sysroot_preprocess() { | ||
125 | install -d ${SYSROOT_DESTDIR}${bindir_crossscripts} | ||
126 | mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV} | ||
127 | } | ||