diff options
Diffstat (limited to 'recipes/llvm/llvm3.2_3.2.bb')
-rw-r--r-- | recipes/llvm/llvm3.2_3.2.bb | 105 |
1 files changed, 0 insertions, 105 deletions
diff --git a/recipes/llvm/llvm3.2_3.2.bb b/recipes/llvm/llvm3.2_3.2.bb deleted file mode 100644 index 71a53c1..0000000 --- a/recipes/llvm/llvm3.2_3.2.bb +++ /dev/null | |||
@@ -1,105 +0,0 @@ | |||
1 | DESCRIPTION = "The Low Level Virtual Machine" | ||
2 | HOMEPAGE = "http://llvm.org" | ||
3 | # 3-clause BSD-like | ||
4 | LICENSE = "NCSA" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=60fdd7739841f04a2ce2171a726be8f3" | ||
6 | |||
7 | DEPENDS = "libffi libxml2-native llvm-common" | ||
8 | |||
9 | SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz" | ||
10 | SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch " | ||
11 | |||
12 | SRC_URI[md5sum] = "71610289bbc819e3e15fdd562809a2d7" | ||
13 | SRC_URI[sha256sum] = "125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343" | ||
14 | |||
15 | S = "${WORKDIR}/llvm-${PV}.src" | ||
16 | |||
17 | inherit autotools perlnative pythonnative | ||
18 | |||
19 | LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build" | ||
20 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" | ||
21 | LLVM_DIR = "llvm${PV}" | ||
22 | |||
23 | EXTRA_OECONF += "--disable-assertions \ | ||
24 | --enable-debug-runtime \ | ||
25 | --disable-expensive-checks \ | ||
26 | --enable-bindings=none \ | ||
27 | --enable-keep-symbols \ | ||
28 | --enable-libffi \ | ||
29 | --enable-optimized \ | ||
30 | --enable-shared \ | ||
31 | --enable-targets=host-only" | ||
32 | EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1" | ||
33 | FILES_${PN} = "${libdir}/lib*.so \ | ||
34 | ${libdir}/${LLVM_DIR}/*" | ||
35 | FILES_${PN}-dbg = "${bindir}/${LLVM_DIR}/.debug \ | ||
36 | ${libdir}/${LLVM_DIR}/.debug \ | ||
37 | ${libdir}/.debug \ | ||
38 | /usr/src/debug" | ||
39 | FILES_${PN}-dev = "${bindir}/${LLVM_DIR} \ | ||
40 | ${includedir}/${LLVM_DIR} \ | ||
41 | ${libdir}/${LLVM_DIR}/BugpointPasses.so \ | ||
42 | ${libdir}/${LLVM_DIR}/LLVMHello.so" | ||
43 | FILES_${PN}-static-dev = "${libdir}/${LLVM_DIR}/*.a" | ||
44 | FILES_SOLIBSDEV = "" | ||
45 | INSANE_SKIP_${PN} = "dev-so" | ||
46 | |||
47 | do_configure_prepend() { | ||
48 | # Remove RPATHs | ||
49 | sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules | ||
50 | |||
51 | # Drop "svn" suffix from version string | ||
52 | sed -i 's/3\.2svn/3.2/g' configure | ||
53 | |||
54 | # Fix paths in llvm-config | ||
55 | sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp | ||
56 | sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp | ||
57 | |||
58 | # Fails to build unless using separate directory from source | ||
59 | mkdir -p ${LLVM_BUILD_DIR} | ||
60 | cd ${LLVM_BUILD_DIR} | ||
61 | } | ||
62 | |||
63 | do_compile() { | ||
64 | cd ${LLVM_BUILD_DIR} | ||
65 | oe_runmake \ | ||
66 | AR="${BUILD_AR}" \ | ||
67 | CC="${BUILD_CC}" \ | ||
68 | CFLAGS="${BUILD_CFLAGS}" \ | ||
69 | CXX="${BUILD_CXX}" \ | ||
70 | CXXFLAGS="${BUILD_CXXFLAGS}" \ | ||
71 | CPP="${BUILD_CPP}" \ | ||
72 | CPPFLAGS="${BUILD_CPPFLAGS}" \ | ||
73 | NM="${BUILD_NM}" \ | ||
74 | RANLIB="${BUILD_RANLIB}" \ | ||
75 | PATH="${STAGING_BINDIR_NATIVE}:$PATH" \ | ||
76 | cross-compile-build-tools | ||
77 | oe_runmake | ||
78 | } | ||
79 | |||
80 | do_install() { | ||
81 | cd ${LLVM_BUILD_DIR} | ||
82 | oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install | ||
83 | |||
84 | mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host | ||
85 | |||
86 | install -d ${D}${bindir}/${LLVM_DIR} | ||
87 | mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/ | ||
88 | |||
89 | install -d ${D}${includedir}/${LLVM_DIR} | ||
90 | mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/ | ||
91 | |||
92 | install -d ${D}${libdir}/${LLVM_DIR} | ||
93 | mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/ | ||
94 | ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so | ||
95 | |||
96 | install -d ${D}${docdir}/${LLVM_DIR} | ||
97 | mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR} | ||
98 | } | ||
99 | |||
100 | SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess" | ||
101 | |||
102 | llvm_sysroot_preprocess() { | ||
103 | install -d ${SYSROOT_DESTDIR}${bindir_crossscripts} | ||
104 | mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV} | ||
105 | } | ||