diff options
Diffstat (limited to 'recipes/mesa/mesa_9.1.3.bb')
-rw-r--r-- | recipes/mesa/mesa_9.1.3.bb | 117 |
1 files changed, 0 insertions, 117 deletions
diff --git a/recipes/mesa/mesa_9.1.3.bb b/recipes/mesa/mesa_9.1.3.bb deleted file mode 100644 index 26a2154..0000000 --- a/recipes/mesa/mesa_9.1.3.bb +++ /dev/null | |||
@@ -1,117 +0,0 @@ | |||
1 | SUMMARY = "A free implementation of the OpenGL API" | ||
2 | DESCRIPTION = "Mesa is an open-source implementation of the OpenGL specification - \ | ||
3 | a system for rendering interactive 3D graphics. \ | ||
4 | A variety of device drivers allows Mesa to be used in many different environments \ | ||
5 | ranging from software emulation to complete hardware acceleration for modern GPUs. \ | ||
6 | Mesa is used as part of the overall Direct Rendering Infrastructure and X.org \ | ||
7 | environment." | ||
8 | |||
9 | HOMEPAGE = "http://mesa3d.org" | ||
10 | BUGTRACKER = "https://bugs.freedesktop.org" | ||
11 | SECTION = "x11" | ||
12 | LICENSE = "MIT" | ||
13 | LIC_FILES_CHKSUM = "file://docs/license.html;md5=42d77d95cba529a3637129be87d6555d" | ||
14 | |||
15 | INC_PR = "r9" | ||
16 | PE = "2" | ||
17 | |||
18 | export WANT_LLVM_RELEASE = "3.2" | ||
19 | |||
20 | DEPENDS = "expat makedepend-native flex-native bison-native llvm${WANT_LLVM_RELEASE}" | ||
21 | |||
22 | PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" | ||
23 | |||
24 | inherit autotools pkgconfig pythonnative | ||
25 | |||
26 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \ | ||
27 | file://EGL-Mutate-NativeDisplayType-depending-on-config.patch \ | ||
28 | file://fix-glsl-cross.patch \ | ||
29 | file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \ | ||
30 | file://0001-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch \ | ||
31 | file://0001-fix-xlib-dependency-from-pipe-loader.patch \ | ||
32 | file://glapi.patch \ | ||
33 | " | ||
34 | |||
35 | SRC_URI[md5sum] = "952ccd03547ed72333b64e1746cf8ada" | ||
36 | SRC_URI[sha256sum] = "8d5dac2202d0355bff5cfd183582ec8167d1d1227b7bb7a669acecbeaa52d766" | ||
37 | |||
38 | S = "${WORKDIR}/Mesa-${PV}" | ||
39 | |||
40 | EXTRA_OECONF = " \ | ||
41 | --enable-opengl \ | ||
42 | --enable-gles2 \ | ||
43 | --enable-egl --with-egl-platforms=fbdev \ | ||
44 | --enable-gallium --enable-gallium-llvm --enable-gallium-egl --with-llvm-shared-libs --with-gallium-drivers="swrast" \ | ||
45 | --enable-shared-glapi \ | ||
46 | --disable-glx \ | ||
47 | --enable-dri --with-dri-drivers="" \ | ||
48 | --disable-gles1 \ | ||
49 | --disable-gles3 \ | ||
50 | --disable-openvg \ | ||
51 | " | ||
52 | |||
53 | # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2) | ||
54 | FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer" | ||
55 | |||
56 | # Multiple virtual/gl providers being built breaks staging | ||
57 | EXCLUDE_FROM_WORLD = "1" | ||
58 | |||
59 | # Remove the mesa dependency on mesa-dev, as mesa is empty | ||
60 | RDEPENDS_${PN}-dev = "" | ||
61 | |||
62 | PACKAGES =+ "libegl-mesa libegl-mesa-dev \ | ||
63 | libglapi libglapi-dev \ | ||
64 | libgles2-mesa libgles2-mesa-dev \ | ||
65 | libegl-gallium \ | ||
66 | " | ||
67 | |||
68 | do_install_append () { | ||
69 | # Drivers never need libtool .la files | ||
70 | rm -f ${D}${libdir}/egl/*.la | ||
71 | rm -f ${D}${libdir}/gallium-pipe/*.la | ||
72 | } | ||
73 | |||
74 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
75 | # they don't get Debian-renamed (which would remove the -mesa suffix), and | ||
76 | # RPROVIDEs/RCONFLICTs on the generic libgl name. | ||
77 | python __anonymous() { | ||
78 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
79 | ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), | ||
80 | ("libgles3",)): | ||
81 | fullp = p[0] + "-mesa" | ||
82 | pkgs = " ".join(p) | ||
83 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
84 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
85 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
86 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
87 | |||
88 | # For -dev, the first element is both the Debian and original name | ||
89 | fullp += "-dev" | ||
90 | pkgs = p[0] + "-dev" | ||
91 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
92 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
93 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
94 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
95 | } | ||
96 | |||
97 | python mesa_populate_packages() { | ||
98 | pipe_drivers_root = os.path.join(d.getVar('libdir', True), "gallium-pipe") | ||
99 | do_split_packages(d, pipe_drivers_root, '^pipe_(.*)\.so$', 'mesa-driver-pipe-%s', 'Mesa %s pipe driver', extra_depends='') | ||
100 | } | ||
101 | |||
102 | PACKAGESPLITFUNCS_prepend = "mesa_populate_packages " | ||
103 | |||
104 | PACKAGES_DYNAMIC += "^mesa-driver-.*" | ||
105 | |||
106 | FILES_libegl-mesa = "${libdir}/libEGL.so.*" | ||
107 | FILES_libgles2-mesa = "${libdir}/libGLESv2.so.*" | ||
108 | FILES_libglapi = "${libdir}/libglapi.so.*" | ||
109 | FILES_libegl-gallium = "${libdir}/egl/egl_gallium.so* ${libdir}/egl/st_GL.so*" | ||
110 | |||
111 | FILES_libegl-mesa-dev = "${libdir}/libEGL.* ${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
112 | FILES_libglapi-dev = "${libdir}/libglapi.*" | ||
113 | FILES_libgles2-mesa-dev = "${libdir}/libGLESv2.* ${includedir}/GLES2 ${libdir}/pkgconfig/glesv2.pc" | ||
114 | |||
115 | FILES_${PN}-dbg += "${libdir}/egl/.debug/* ${libdir}/gallium-pipe/.debug" | ||
116 | |||
117 | |||