summaryrefslogtreecommitdiffstats
path: root/recipes/opengldummy/qtglesstream-dummy-client.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opengldummy/qtglesstream-dummy-client.bb')
-rw-r--r--recipes/opengldummy/qtglesstream-dummy-client.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/opengldummy/qtglesstream-dummy-client.bb b/recipes/opengldummy/qtglesstream-dummy-client.bb
new file mode 100644
index 0000000..b3b3e37
--- /dev/null
+++ b/recipes/opengldummy/qtglesstream-dummy-client.bb
@@ -0,0 +1,38 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "QtGlesStream dummy client provides headers and a dummy library for EGL/GLES"
24SECTION = "devel"
25LICENSE = "CLOSED"
26
27PV = "1.0.0"
28
29require opengldummy.inc
30
31do_compile() {
32 ${CC} -DQGS_BUILD_CLIENT_DLL -fPIC -shared -I${WORKDIR}/headers -o libQtGlesStreamClient.so ${WORKDIR}/egl.cpp ${WORKDIR}/gles2.cpp
33}
34
35do_install_append() {
36 install -m 0755 -d ${D}${libdir}
37 install -m 0755 ${S}/libQtGlesStreamClient.so ${D}${libdir}
38}