summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/nativesdk-prebuild-python.inc (renamed from recipes/python/nativesdk-prebuild-python.bb)33
-rw-r--r--recipes/python/nativesdk-prebuild-python_i686.bb42
-rw-r--r--recipes/python/nativesdk-prebuild-python_x86_64.bb42
3 files changed, 97 insertions, 20 deletions
diff --git a/recipes/python/nativesdk-prebuild-python.bb b/recipes/python/nativesdk-prebuild-python.inc
index e8edb9e..3d8c083 100644
--- a/recipes/python/nativesdk-prebuild-python.bb
+++ b/recipes/python/nativesdk-prebuild-python.inc
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -29,32 +29,25 @@
29 29
30LICENSE = "PSFv2" 30LICENSE = "PSFv2"
31 31
32LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Python-2.0;md5=a5c8025e305fb49e6d405769358851f6" 32LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4b8a9367e6bb2acb6f26dc08654f6ee5"
33 33
34inherit bin_package nativesdk 34do_unpack[depends] += "p7zip-native:do_populate_sysroot"
35 35
36COMPATIBLE_HOST = ".*-mingw.*" 36inherit bin_package nativesdk python3-dir
37 37
38SRC_URI[md5sum] = "6d37712f01fa836b1303141a6d4cabda" 38PV = "3.5.2"
39SRC_URI[sha256sum] = "3835868c171dddb8cb68ed5578b6d4d639387a038e999a5b008f393b704d6ad7"
40SRC_URI = "http://download.qt.io/development_releases/prebuilt/gdb/build-prerequisites/python.zip"
41 39
42S = "${WORKDIR}" 40S = "${WORKDIR}"
43 41
44do_install() { 42do_install() {
45 install -d ${D}${bindir} 43 install -d ${D}${includedir}/${PYTHON_DIR}
46 install ${WORKDIR}/python/python27.dll ${D}${bindir} 44 install -m 0644 ${S}/include/* ${D}${includedir}/${PYTHON_DIR}
47 install -d ${D}${includedir} 45
48 install ${WORKDIR}/python/include/* ${D}${includedir}
49 install -d ${D}${libdir} 46 install -d ${D}${libdir}
50 install ${WORKDIR}/python/libs/* ${D}${libdir} 47 install -m 0644 ${S}/libs/*.a ${D}${libdir}
51 install -d ${D}${libdir}/python2.7
52 cp -r ${WORKDIR}/python/lib/* ${D}${libdir}/python2.7
53}
54 48
55sysroot_stage_dirs_append() { 49 install -d ${D}${bindir}
56 sysroot_stage_dir $from${bindir} $to${bindir} 50 install -m 0644 ${S}/python.exe ${D}${bindir}
51 install -m 0644 ${S}/python35.dll ${D}${bindir}
52 install -m 0644 ${S}/python35.zip ${D}${bindir}
57} 53}
58
59# requires /usr/local/bin/python, but no providers found
60INSANE_SKIP_${PN} += "file-rdeps"
diff --git a/recipes/python/nativesdk-prebuild-python_i686.bb b/recipes/python/nativesdk-prebuild-python_i686.bb
new file mode 100644
index 0000000..2ff4f76
--- /dev/null
+++ b/recipes/python/nativesdk-prebuild-python_i686.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "i686.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
40SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
41SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
42SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
diff --git a/recipes/python/nativesdk-prebuild-python_x86_64.bb b/recipes/python/nativesdk-prebuild-python_x86_64.bb
new file mode 100644
index 0000000..8e69fbd
--- /dev/null
+++ b/recipes/python/nativesdk-prebuild-python_x86_64.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "x86_64.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
40SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
41SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
42SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"