diff options
Diffstat (limited to 'recipes/python')
-rw-r--r-- | recipes/python/nativesdk-prebuild-python.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/python/nativesdk-prebuild-python.bb b/recipes/python/nativesdk-prebuild-python.bb new file mode 100644 index 0000000..14e8278 --- /dev/null +++ b/recipes/python/nativesdk-prebuild-python.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | LICENSE = "PSFv2" | ||
24 | |||
25 | inherit bin_package nativesdk | ||
26 | |||
27 | SRC_URI[md5sum] = "6d37712f01fa836b1303141a6d4cabda" | ||
28 | SRC_URI[sha256sum] = "3835868c171dddb8cb68ed5578b6d4d639387a038e999a5b008f393b704d6ad7" | ||
29 | SRC_URI = "http://download.qt.io/development_releases/prebuilt/gdb/build-prerequisites/python.zip" | ||
30 | |||
31 | S = "${WORKDIR}" | ||
32 | |||
33 | do_install() { | ||
34 | install -d ${D}${bindir} | ||
35 | install ${WORKDIR}/python/python27.dll ${D}${bindir} | ||
36 | install -d ${D}${includedir} | ||
37 | install ${WORKDIR}/python/include/* ${D}${includedir} | ||
38 | install -d ${D}${libdir} | ||
39 | install ${WORKDIR}/python/libs/* ${D}${libdir} | ||
40 | install -d ${D}${libdir}/python2.7 | ||
41 | cp -r ${WORKDIR}/python/lib/* ${D}${libdir}/python2.7 | ||
42 | } | ||
43 | |||
44 | sysroot_stage_dirs_append() { | ||
45 | install -d ${STAGING_BINDIR} | ||
46 | cp ${WORKDIR}/python/python27.dll -d ${STAGING_BINDIR} | ||
47 | } | ||