summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/nativesdk-prebuild-python.bb60
-rw-r--r--recipes/python/python3-native_%.bbappend1
-rw-r--r--recipes/python/python3-virtualenv.bb21
-rw-r--r--recipes/python/python3_%.bbappend11
4 files changed, 0 insertions, 93 deletions
diff --git a/recipes/python/nativesdk-prebuild-python.bb b/recipes/python/nativesdk-prebuild-python.bb
deleted file mode 100644
index e8edb9e..0000000
--- a/recipes/python/nativesdk-prebuild-python.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "PSFv2"
31
32LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Python-2.0;md5=a5c8025e305fb49e6d405769358851f6"
33
34inherit bin_package nativesdk
35
36COMPATIBLE_HOST = ".*-mingw.*"
37
38SRC_URI[md5sum] = "6d37712f01fa836b1303141a6d4cabda"
39SRC_URI[sha256sum] = "3835868c171dddb8cb68ed5578b6d4d639387a038e999a5b008f393b704d6ad7"
40SRC_URI = "http://download.qt.io/development_releases/prebuilt/gdb/build-prerequisites/python.zip"
41
42S = "${WORKDIR}"
43
44do_install() {
45 install -d ${D}${bindir}
46 install ${WORKDIR}/python/python27.dll ${D}${bindir}
47 install -d ${D}${includedir}
48 install ${WORKDIR}/python/include/* ${D}${includedir}
49 install -d ${D}${libdir}
50 install ${WORKDIR}/python/libs/* ${D}${libdir}
51 install -d ${D}${libdir}/python2.7
52 cp -r ${WORKDIR}/python/lib/* ${D}${libdir}/python2.7
53}
54
55sysroot_stage_dirs_append() {
56 sysroot_stage_dir $from${bindir} $to${bindir}
57}
58
59# requires /usr/local/bin/python, but no providers found
60INSANE_SKIP_${PN} += "file-rdeps"
diff --git a/recipes/python/python3-native_%.bbappend b/recipes/python/python3-native_%.bbappend
deleted file mode 100644
index 9015f3f..0000000
--- a/recipes/python/python3-native_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
diff --git a/recipes/python/python3-virtualenv.bb b/recipes/python/python3-virtualenv.bb
deleted file mode 100644
index cc091b8..0000000
--- a/recipes/python/python3-virtualenv.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Virtual Python Environment builder"
2HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43"
6
7PV="15.1.0"
8SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz"
9
10SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716"
11SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/"
14UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/virtualenv-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20inherit setuptools3
21
diff --git a/recipes/python/python3_%.bbappend b/recipes/python/python3_%.bbappend
deleted file mode 100644
index b3a5eb7..0000000
--- a/recipes/python/python3_%.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}