summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-am33x_2013.01.01.bbappend22
-rw-r--r--recipes/u-boot/u-boot-beagleboard_2011.09.bbappend22
-rw-r--r--recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch25
-rw-r--r--recipes/u-boot/u-boot-script-boundary_git.bbappend22
-rw-r--r--recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch25
-rw-r--r--recipes/u-boot/u-boot-ti-staging_2013.10.bbappend26
6 files changed, 130 insertions, 12 deletions
diff --git a/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend b/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
index 48d7885..2b1c656 100644
--- a/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
+++ b/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
@@ -1,3 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
1FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
2SRC_URI += " \ 24SRC_URI += " \
3 file://0001-am335x-evm-disable-console-cursor-blinking.patch \ 25 file://0001-am335x-evm-disable-console-cursor-blinking.patch \
diff --git a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
index 787ac42..f6fbde1 100644
--- a/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
+++ b/recipes/u-boot/u-boot-beagleboard_2011.09.bbappend
@@ -1,3 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2SRC_URI += " \ 24SRC_URI += " \
3 file://0001-beagle-change-default-kernel-args.patch \ 25 file://0001-beagle-change-default-kernel-args.patch \
diff --git a/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
index 3c65a20..d97921c 100644
--- a/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
+++ b/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
@@ -1,24 +1,25 @@
1From 6b894707404a1aeb3072d4b3bfc486ff9ad37ac4 Mon Sep 17 00:00:00 2001 1From b21614109fb3cca15c4b0d296b3ab6cc1b778e3a Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com> 2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Tue, 9 Jul 2013 15:31:30 +0300 3Date: Fri, 10 Jan 2014 12:37:20 +0200
4Subject: [PATCH] nitrogen6x: disable console cursor blinking 4Subject: [PATCH] nitrogen6x: disable console cursor blinking
5 5
6--- 6---
7 board/boundary/nitrogen6x/6x_bootscript.txt | 2 +- 7 board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-) 8 1 file changed, 1 insertion(+), 1 deletion(-)
9 9
10diff --git a/board/boundary/nitrogen6x/6x_bootscript.txt b/board/boundary/nitrogen6x/6x_bootscript.txt 10diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt
11index 1d766ca..80b91ea 100644 11index d933fa0..2d7c575 100644
12--- a/board/boundary/nitrogen6x/6x_bootscript.txt 12--- a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt
13+++ b/board/boundary/nitrogen6x/6x_bootscript.txt 13+++ b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt
14@@ -53,6 +53,6 @@ done 14@@ -56,7 +56,7 @@ while test "4" -ne $nextcon ; do
15 done
15 16
16 setenv bootargs $bootargs $fbmem 17 setenv bootargs $bootargs $fbmem
18-setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait"
19+setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 rootwait"
17 20
18-setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 ; 21 if itest.s x$bootpart == x ; then
19+setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p2 rootwait consoleblank=0 vt.global_cursor_default=0 ; 22 bootpart=1
20 ${fs}load mmc ${disk}:1 10800000 uImage && bootm 10800000 ; echo "Error loading kernel image"
21
22-- 23--
231.7.10.4 241.7.10.4
24 25
diff --git a/recipes/u-boot/u-boot-script-boundary_git.bbappend b/recipes/u-boot/u-boot-script-boundary_git.bbappend
index c845717..083b2fd 100644
--- a/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/recipes/u-boot/u-boot-script-boundary_git.bbappend
@@ -1,3 +1,25 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
1FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
2SRC_URI += " \ 24SRC_URI += " \
3 file://0001-nitrogen6x-disable-console-cursor-blinking.patch \ 25 file://0001-nitrogen6x-disable-console-cursor-blinking.patch \
diff --git a/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch b/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
new file mode 100644
index 0000000..25dd9e4
--- /dev/null
+++ b/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
@@ -0,0 +1,25 @@
1From bde714b9bfeafe46abc1078c09f6efac0e7b6478 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Wed, 22 Jan 2014 11:30:59 +0200
4Subject: [PATCH] BBB: disable console cursor blinking
5
6---
7 include/configs/am335x_evm.h | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index d53f17d..1b3d2a4 100644
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -59,6 +59,8 @@
15 "ramrootfstype=ext2\0" \
16 "mmcargs=setenv bootargs console=${console} " \
17 "${optargs} " \
18+ "consoleblank=0 " \
19+ "vt.global_cursor_default=0 " \
20 "root=${mmcroot} " \
21 "rootfstype=${mmcrootfstype}\0" \
22 "spiroot=/dev/mtdblock4 rw\0" \
23--
241.8.3.2
25
diff --git a/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend b/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
new file mode 100644
index 0000000..bad928b
--- /dev/null
+++ b/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-BBB-disable-console-cursor-blinking.patch \
26 "