summaryrefslogtreecommitdiffstats
path: root/recipes/virtualbox/mount-vboxsf_4.3.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/virtualbox/mount-vboxsf_4.3.30.bb')
-rw-r--r--recipes/virtualbox/mount-vboxsf_4.3.30.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/virtualbox/mount-vboxsf_4.3.30.bb b/recipes/virtualbox/mount-vboxsf_4.3.30.bb
new file mode 100644
index 0000000..171ba7e
--- /dev/null
+++ b/recipes/virtualbox/mount-vboxsf_4.3.30.bb
@@ -0,0 +1,51 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "VirtualBox Guest Additions for Linux: mount"
24LICENSE = "GPLv2"
25LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
26
27SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2 \
28 file://mount-vboxsf.sh \
29 "
30
31SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd"
32SRC_URI[sha256sum] = "ea9569ec16cd6202ee61bcadb2506d31ac12fd343adb91565773a05eaaea9a36"
33
34S = "${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/sharedfolders"
35
36do_compile() {
37 ${CC} mount.vboxsf.c vbsfmount.c -o mount.vboxsf
38}
39
40do_install() {
41 install -m 0755 -d ${D}${bindir}/
42 install -m 0755 mount.vboxsf ${D}${bindir}/
43
44 install -m 0755 -d ${D}${sysconfdir}/init.d
45 install -m 0755 ${WORKDIR}/mount-vboxsf.sh ${D}${sysconfdir}/init.d/
46}
47
48INITSCRIPT_NAME = "mount-vboxsf.sh"
49INITSCRIPT_PARAMS = "defaults 33"
50
51inherit update-rc.d