summaryrefslogtreecommitdiffstats
path: root/scripts/update-qt5-modules.sh
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/update-qt5-modules.sh')
-rwxr-xr-xscripts/update-qt5-modules.sh5
1 files changed, 2 insertions, 3 deletions
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh
index e6d945f..4ae42e8 100755
--- a/scripts/update-qt5-modules.sh
+++ b/scripts/update-qt5-modules.sh
@@ -53,9 +53,8 @@ for S in $SHA1S; do
53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then 53 elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then
54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* 54 sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb*
55 echo "qtlocation (mapboxgl) -> ${SHA1}" 55 echo "qtlocation (mapboxgl) -> ${SHA1}"
56 elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then 56 elif [ "${PROJECT}" = "qtenginio" ] || [ "${PROJECT}" = "qtquick1" ] || [ "${PROJECT}" = "qtsystems" ]; then
57 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb 57 echo "${PROJECT} -> ignored"
58 echo "qtquickcompiler -> ${SHA1}"
59 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then 58 elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then
60 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* 59 sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb*
61 echo "${PROJECT} -> ${SHA1}" 60 echo "${PROJECT} -> ${SHA1}"