diff options
Diffstat (limited to 'scripts')
-rwxr-xr-x | scripts/configure-qtcreator.sh | 173 | ||||
-rw-r--r-- | scripts/manifest.xml | 41 | ||||
-rwxr-xr-x | scripts/setup-environment.sh | 18 | ||||
-rwxr-xr-x | scripts/update-qt5-modules.sh | 5 |
4 files changed, 38 insertions, 199 deletions
diff --git a/scripts/configure-qtcreator.sh b/scripts/configure-qtcreator.sh deleted file mode 100755 index d6e9c07..0000000 --- a/scripts/configure-qtcreator.sh +++ /dev/null | |||
@@ -1,173 +0,0 @@ | |||
1 | #!/bin/bash | ||
2 | ############################################################################ | ||
3 | ## | ||
4 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
5 | ## Contact: https://www.qt.io/licensing/ | ||
6 | ## | ||
7 | ## This file is part of the Boot to Qt meta layer. | ||
8 | ## | ||
9 | ## $QT_BEGIN_LICENSE:GPL$ | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at https://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## GNU General Public License Usage | ||
19 | ## Alternatively, this file may be used under the terms of the GNU | ||
20 | ## General Public License version 3 or (at your option) any later version | ||
21 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
22 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
23 | ## included in the packaging of this file. Please review the following | ||
24 | ## information to ensure the GNU General Public License requirements will | ||
25 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
26 | ## | ||
27 | ## $QT_END_LICENSE$ | ||
28 | ## | ||
29 | ############################################################################ | ||
30 | |||
31 | set -e | ||
32 | |||
33 | ABI="arm-linux-generic-elf-32bit" | ||
34 | CONFIG="" | ||
35 | |||
36 | printUsage () | ||
37 | { | ||
38 | echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>] [--appman]" | ||
39 | } | ||
40 | |||
41 | while test -n "$1"; do | ||
42 | case "$1" in | ||
43 | "--remove") | ||
44 | REMOVEONLY=1 | ||
45 | ;; | ||
46 | "--appman") | ||
47 | APPMAN=1 | ||
48 | ;; | ||
49 | "--qtcreator") | ||
50 | shift | ||
51 | QTCREATOR=$1 | ||
52 | ;; | ||
53 | "--config") | ||
54 | shift | ||
55 | CONFIG=$1 | ||
56 | ;; | ||
57 | "--name") | ||
58 | shift | ||
59 | NAME=$1 | ||
60 | ;; | ||
61 | *) | ||
62 | printUsage | ||
63 | exit 0 | ||
64 | ;; | ||
65 | esac | ||
66 | shift | ||
67 | done | ||
68 | |||
69 | if [ ! -f "$CONFIG" ]; then | ||
70 | printUsage | ||
71 | exit 1 | ||
72 | fi | ||
73 | |||
74 | if [ -z "${QTCREATOR}" ]; then | ||
75 | SDKTOOL="${HOME}/Qt/Tools/QtCreator/libexec/qtcreator/sdktool" | ||
76 | else | ||
77 | SDKTOOL="${QTCREATOR}/libexec/qtcreator/sdktool" | ||
78 | fi | ||
79 | if [ ! -x ${SDKTOOL} ]; then | ||
80 | echo "Cannot find 'sdktool' from QtCreator" | ||
81 | printUsage | ||
82 | exit 1 | ||
83 | fi | ||
84 | |||
85 | source $CONFIG | ||
86 | |||
87 | MKSPEC="devices/linux-oe-generic-g++" | ||
88 | MKSPECPATH=$(find ${OECORE_TARGET_SYSROOT} -name $(basename ${MKSPEC})) | ||
89 | if [ ! -d "${MKSPECPATH}" ]; then | ||
90 | echo "Error: could not find mkspec ${MKSPEC} from the toolchain" | ||
91 | exit 1 | ||
92 | fi | ||
93 | |||
94 | MACHINE=$(grep '^MACHINE' ${MKSPECPATH}/../../qdevice.pri | cut -d'=' -f2 | tr -d ' ') | ||
95 | |||
96 | RELEASE=$(qmake -query QT_VERSION) | ||
97 | |||
98 | NAME=${NAME:-"Custom Qt ${RELEASE} ${MACHINE}"} | ||
99 | BASEID="byos.${RELEASE}.${MACHINE}" | ||
100 | |||
101 | ${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true | ||
102 | ${SDKTOOL} rmKit --id ${BASEID}.am.kit 2>/dev/null || true | ||
103 | ${SDKTOOL} rmQt --id ${BASEID}.qt || true | ||
104 | ${SDKTOOL} rmQt --id ${BASEID}.am.qt || true | ||
105 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true | ||
106 | ${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true | ||
107 | ${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true | ||
108 | |||
109 | if [ -n "${REMOVEONLY}" ]; then | ||
110 | echo "Kit removed: ${NAME}" | ||
111 | exit 0 | ||
112 | fi | ||
113 | |||
114 | ${SDKTOOL} addTC \ | ||
115 | --id "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ | ||
116 | --name "GCC (${NAME})" \ | ||
117 | --path "$(type -p ${CC})" \ | ||
118 | --abi "${ABI}" \ | ||
119 | --language 1 | ||
120 | |||
121 | ${SDKTOOL} addTC \ | ||
122 | --id "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ | ||
123 | --name "G++ (${NAME})" \ | ||
124 | --path "$(type -p ${CXX})" \ | ||
125 | --abi "${ABI}" \ | ||
126 | --language 2 | ||
127 | |||
128 | ${SDKTOOL} addDebugger \ | ||
129 | --id "${BASEID}.gdb" \ | ||
130 | --name "GDB (${NAME})" \ | ||
131 | --engine 1 \ | ||
132 | --binary "$(type -p ${GDB})" \ | ||
133 | --abis "${ABI}" | ||
134 | |||
135 | ${SDKTOOL} addQt \ | ||
136 | --id "${BASEID}.qt" \ | ||
137 | --name "${NAME}" \ | ||
138 | --type "Qdb.EmbeddedLinuxQt" \ | ||
139 | --qmake "$(type -p qmake)" | ||
140 | |||
141 | ${SDKTOOL} addKit \ | ||
142 | --id "${BASEID}.kit" \ | ||
143 | --name "${NAME}" \ | ||
144 | --qt "${BASEID}.qt" \ | ||
145 | --debuggerid "${BASEID}.gdb" \ | ||
146 | --sysroot "${SDKTARGETSYSROOT}" \ | ||
147 | --devicetype "QdbLinuxOsType" \ | ||
148 | --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ | ||
149 | --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ | ||
150 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | ||
151 | --mkspec "${MKSPEC}" | ||
152 | |||
153 | if [ -n "${APPMAN}" ]; then | ||
154 | ${SDKTOOL} addQt \ | ||
155 | --id "${BASEID}.am.qt" \ | ||
156 | --name "${NAME} [Application Manager]" \ | ||
157 | --type "AM.Qt" \ | ||
158 | --qmake "$(type -p qmake)" | ||
159 | |||
160 | ${SDKTOOL} addKit \ | ||
161 | --id "${BASEID}.am.kit" \ | ||
162 | --name "${NAME} [Application Manager]" \ | ||
163 | --qt "${BASEID}.am.qt" \ | ||
164 | --debuggerid "${BASEID}.gdb" \ | ||
165 | --sysroot "${SDKTARGETSYSROOT}" \ | ||
166 | --devicetype "AM.Device.Type" \ | ||
167 | --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ | ||
168 | --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \ | ||
169 | --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \ | ||
170 | --mkspec "${MKSPEC}" | ||
171 | fi | ||
172 | |||
173 | echo "Configured Qt Creator with new kit: ${NAME}" | ||
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index fb900be..9a87860 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -13,52 +13,54 @@ | |||
13 | <remote fetch="git://github.com/renesas-rcar" name="renesas"/> | 13 | <remote fetch="git://github.com/renesas-rcar" name="renesas"/> |
14 | <remote fetch="git://git.linaro.org/openembedded" name="linaro"/> | 14 | <remote fetch="git://git.linaro.org/openembedded" name="linaro"/> |
15 | <remote fetch="git://git.toradex.com" name="toradex"/> | 15 | <remote fetch="git://git.toradex.com" name="toradex"/> |
16 | <remote fetch="git://github.com/boundarydevices" name="boundary"/> | ||
17 | <remote fetch="git://github.com/toradex" name="toradex-github"/> | ||
16 | 18 | ||
17 | <project name="poky" | 19 | <project name="poky" |
18 | remote="yocto" | 20 | remote="yocto" |
19 | revision="4f6027c30ae2b07a238e7fec63f69169e6a70cf9" | 21 | revision="b9ad197bbc88cad4ef8d2245a2d262b8d8dd757e" |
20 | path="sources/poky"/> | 22 | path="sources/poky"/> |
21 | <project name="meta-openembedded" | 23 | <project name="meta-openembedded" |
22 | remote="oe-mirror" | 24 | remote="oe-mirror" |
23 | revision="b40116cf457b88a2db14b86fda9627fb34d56ae6" | 25 | revision="b2ce52334cf88e07f703cf25ced92302edd5b0e9" |
24 | path="sources/meta-openembedded"/> | 26 | path="sources/meta-openembedded"/> |
25 | <project name="meta-qt5" | 27 | <project name="meta-qt5" |
26 | remote="qtyocto" | 28 | remote="qtyocto" |
27 | revision="5d375076a9c2b2e39f99012d3519a1cb2ff5811d" | 29 | revision="d6b6664ef23c38db48e48be36b90a34ae92dc558" |
28 | path="sources/meta-qt5"/> | 30 | path="sources/meta-qt5"/> |
29 | <project name="meta-mingw" | 31 | <project name="meta-mingw" |
30 | remote="qtyocto" | 32 | remote="qtyocto" |
31 | path="sources/meta-mingw" | 33 | revision="27ccecd47b5e745d4c6a11708dd42a90cc235fb3" |
32 | revision="4a621def8529c3a55c6fcaef72e3b1832a9327b3"/> | 34 | path="sources/meta-mingw"/> |
33 | 35 | ||
34 | <project name="meta-freescale" | 36 | <project name="meta-freescale" |
35 | remote="freescale" | 37 | remote="freescale" |
36 | revision="05681fdf8298bb441c15135eae424c7601b07e98" | 38 | revision="06178400afbd641a6709473fd21d893dcd3cfbfa" |
37 | path="sources/meta-freescale" | 39 | path="sources/meta-freescale" |
38 | groups="notdefault,external,fsl,toradex,ti,smx6,renesas-gen3"/> | 40 | groups="notdefault,external,fsl,toradex,ti,smx6,renesas-gen3,boundary,fsl-imx8"/> |
39 | <project name="meta-freescale-3rdparty" | 41 | <project name="meta-freescale-3rdparty" |
40 | remote="freescale" | 42 | remote="freescale" |
41 | revision="1879485e63ce369292c89b5902ff6df13509090b" | 43 | revision="9613dbc02ca970122a01c935bc9e5789ced73a9d" |
42 | path="sources/meta-freescale-3rdparty" | 44 | path="sources/meta-freescale-3rdparty" |
43 | groups="notdefault,external,fsl,toradex,smx6"/> | 45 | groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8"/> |
44 | <project name="meta-ti" | 46 | <project name="meta-ti" |
45 | remote="yocto" | 47 | remote="yocto" |
46 | revision="0862a33b8d642e5fad031a78f90410d497453415" | 48 | revision="aca8f5d6ff8a529e00bdeae5b401c791ed6ecb2b" |
47 | path="sources/meta-ti" | 49 | path="sources/meta-ti" |
48 | groups="notdefault,external,ti"/> | 50 | groups="notdefault,external,ti"/> |
49 | <project name="meta-raspberrypi" | 51 | <project name="meta-raspberrypi" |
50 | remote="yocto" | 52 | remote="yocto" |
51 | revision="380bf2ff445c2049bdea15f3bb36e8cb36540345" | 53 | revision="8ba2d6fc80b31c87d25c87c863e2a77752b07c3c" |
52 | path="sources/meta-raspberrypi" | 54 | path="sources/meta-raspberrypi" |
53 | groups="notdefault,external,rpi"/> | 55 | groups="notdefault,external,rpi"/> |
54 | <project name="meta-intel" | 56 | <project name="meta-intel" |
55 | remote="intel" | 57 | remote="intel" |
56 | revision="6add41510412ca196efb3e4f949d403a8b6f35d7" | 58 | revision="7e8f98aa326f16edd679a95f7bb2daf4256479f3" |
57 | path="sources/meta-intel" | 59 | path="sources/meta-intel" |
58 | groups="notdefault,external,intel"/> | 60 | groups="notdefault,external,intel"/> |
59 | <project name="meta-tegra" | 61 | <project name="meta-tegra" |
60 | remote="madisongh" | 62 | remote="madisongh" |
61 | revision="fba09b70a8ac36248e5fcea611e3bb661bb089fc" | 63 | revision="4aea5e3785dc400e31981467f475b54e652dbd67" |
62 | path="sources/meta-tegra" | 64 | path="sources/meta-tegra" |
63 | groups="notdefault,external,jetson"/> | 65 | groups="notdefault,external,jetson"/> |
64 | <project name="meta-renesas" | 66 | <project name="meta-renesas" |
@@ -68,7 +70,7 @@ | |||
68 | groups="notdefault,external,renesas-gen3"/> | 70 | groups="notdefault,external,renesas-gen3"/> |
69 | <project name="meta-linaro" | 71 | <project name="meta-linaro" |
70 | remote="linaro" | 72 | remote="linaro" |
71 | revision="c44bd0ebc8ca2e6201996ef7cba8b71421d3aff7" | 73 | revision="74dacb34c13d1c85fe4627a890b9c04940f9ffeb" |
72 | path="sources/meta-linaro" | 74 | path="sources/meta-linaro" |
73 | groups="notdefault,external,renesas-gen3"/> | 75 | groups="notdefault,external,renesas-gen3"/> |
74 | <project name="meta-toradex-bsp-common" | 76 | <project name="meta-toradex-bsp-common" |
@@ -81,6 +83,16 @@ | |||
81 | revision="45c33b79a734d016dddb997c1895b53202286f23" | 83 | revision="45c33b79a734d016dddb997c1895b53202286f23" |
82 | path="sources/meta-toradex-nxp" | 84 | path="sources/meta-toradex-nxp" |
83 | groups="notdefault,external,toradex"/> | 85 | groups="notdefault,external,toradex"/> |
86 | <project name="meta-boundary" | ||
87 | remote="boundary" | ||
88 | revision="42b00061076b2a6e15c1eeed7da6fc14a0dae9d8" | ||
89 | path="sources/meta-boundary" | ||
90 | groups="notdefault,external,boundary"/> | ||
91 | <project name="meta-fsl-bsp-release" | ||
92 | remote="toradex-github" | ||
93 | revision="d2b0d14c82da830584bc7f43ba1b83097c890454" | ||
94 | path="sources/meta-fsl-bsp-release" | ||
95 | groups="notdefault,external,fsl-imx8"/> | ||
84 | 96 | ||
85 | <project name="nvidia-layer" | 97 | <project name="nvidia-layer" |
86 | remote="playground" | 98 | remote="playground" |
@@ -103,4 +115,3 @@ | |||
103 | path="sources/meta-smx6" | 115 | path="sources/meta-smx6" |
104 | groups="notdefault,internal"/> | 116 | groups="notdefault,internal"/> |
105 | </manifest> | 117 | </manifest> |
106 | |||
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh index fbe8672..3045e3c 100755 --- a/scripts/setup-environment.sh +++ b/scripts/setup-environment.sh | |||
@@ -56,10 +56,16 @@ BUILDDIRECTORY=${BUILDDIRECTORY:-build-${MACHINE}} | |||
56 | 56 | ||
57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | 57 | if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then |
58 | case ${MACHINE} in | 58 | case ${MACHINE} in |
59 | apalis-imx8|imx8qmlpddr4arm2) | ||
60 | LAYERSCONF="bblayers.conf.fsl-imx8.sample" | ||
61 | ;; | ||
59 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) | 62 | apalis-imx6|colibri-imx6|colibri-vf|colibri-imx7) |
60 | LAYERSCONF="bblayers.conf.toradex.sample" | 63 | LAYERSCONF="bblayers.conf.toradex.sample" |
61 | ;; | 64 | ;; |
62 | imx6qsabresd|imx6dlsabresd|nitrogen6x|imx7dsabresd|imx7s-warp) | 65 | nitrogen6x|nitrogen7) |
66 | LAYERSCONF="bblayers.conf.boundary.sample" | ||
67 | ;; | ||
68 | imx6qsabresd|imx6dlsabresd|imx7dsabresd|imx7s-warp) | ||
63 | LAYERSCONF="bblayers.conf.fsl.sample" | 69 | LAYERSCONF="bblayers.conf.fsl.sample" |
64 | ;; | 70 | ;; |
65 | smarc-samx6i) | 71 | smarc-samx6i) |
@@ -83,7 +89,7 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | |||
83 | emulator) | 89 | emulator) |
84 | LAYERSCONF="bblayers.conf.emulator.sample" | 90 | LAYERSCONF="bblayers.conf.emulator.sample" |
85 | ;; | 91 | ;; |
86 | jetson-tx1|jetson-tk1) | 92 | jetson-tx1|jetson-tx2|jetson-tk1) |
87 | LAYERSCONF="bblayers.conf.jetson.sample" | 93 | LAYERSCONF="bblayers.conf.jetson.sample" |
88 | ;; | 94 | ;; |
89 | *) | 95 | *) |
@@ -93,18 +99,14 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then | |||
93 | esac | 99 | esac |
94 | 100 | ||
95 | mkdir -p ${PWD}/${BUILDDIRECTORY}/conf | 101 | mkdir -p ${PWD}/${BUILDDIRECTORY}/conf |
96 | cp ${PWD}/sources/meta-boot2qt/conf/${LAYERSCONF} ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf | 102 | cp ${PWD}/sources/meta-boot2qt/meta-boot2qt-distro/conf/${LAYERSCONF} ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf |
97 | |||
98 | if [ ! -d ${PWD}/sources/meta-qt5 ]; then | ||
99 | sed -i -e '/meta-qt5/d' ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf | ||
100 | fi | ||
101 | 103 | ||
102 | if [ ! -d ${PWD}/sources/meta-boot2qt/.git ]; then | 104 | if [ ! -d ${PWD}/sources/meta-boot2qt/.git ]; then |
103 | QT_SDK_PATH=$(readlink -f ${PWD}/sources/meta-boot2qt/../../../../) | 105 | QT_SDK_PATH=$(readlink -f ${PWD}/sources/meta-boot2qt/../../../../) |
104 | fi | 106 | fi |
105 | fi | 107 | fi |
106 | 108 | ||
107 | export TEMPLATECONF="${PWD}/sources/meta-boot2qt/conf" | 109 | export TEMPLATECONF="${PWD}/sources/meta-boot2qt/meta-boot2qt-distro/conf" |
108 | . sources/poky/oe-init-build-env ${BUILDDIRECTORY} | 110 | . sources/poky/oe-init-build-env ${BUILDDIRECTORY} |
109 | 111 | ||
110 | # use sources from Qt SDK if that is available | 112 | # use sources from Qt SDK if that is available |
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh index e6d945f..4ae42e8 100755 --- a/scripts/update-qt5-modules.sh +++ b/scripts/update-qt5-modules.sh | |||
@@ -53,9 +53,8 @@ for S in $SHA1S; do | |||
53 | elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then | 53 | elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then |
54 | sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* | 54 | sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* |
55 | echo "qtlocation (mapboxgl) -> ${SHA1}" | 55 | echo "qtlocation (mapboxgl) -> ${SHA1}" |
56 | elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then | 56 | elif [ "${PROJECT}" = "qtenginio" ] || [ "${PROJECT}" = "qtquick1" ] || [ "${PROJECT}" = "qtsystems" ]; then |
57 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb | 57 | echo "${PROJECT} -> ignored" |
58 | echo "qtquickcompiler -> ${SHA1}" | ||
59 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then | 58 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then |
60 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* | 59 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* |
61 | echo "${PROJECT} -> ${SHA1}" | 60 | echo "${PROJECT} -> ${SHA1}" |