diff options
Diffstat (limited to 'scripts')
-rw-r--r-- | scripts/manifest.xml | 2 | ||||
-rwxr-xr-x | scripts/update-qt5-modules.sh | 5 |
2 files changed, 3 insertions, 4 deletions
diff --git a/scripts/manifest.xml b/scripts/manifest.xml index 1aa053b..46c5f2a 100644 --- a/scripts/manifest.xml +++ b/scripts/manifest.xml | |||
@@ -25,7 +25,7 @@ | |||
25 | path="sources/meta-openembedded"/> | 25 | path="sources/meta-openembedded"/> |
26 | <project name="meta-qt5" | 26 | <project name="meta-qt5" |
27 | remote="qtyocto" | 27 | remote="qtyocto" |
28 | revision="a358108b09762390ec951f560540bb99aaf9f2a2" | 28 | revision="50c4963980164ae0e9992d652fd934d85fd2400e" |
29 | path="sources/meta-qt5"/> | 29 | path="sources/meta-qt5"/> |
30 | <project name="meta-mingw" | 30 | <project name="meta-mingw" |
31 | remote="qtyocto" | 31 | remote="qtyocto" |
diff --git a/scripts/update-qt5-modules.sh b/scripts/update-qt5-modules.sh index e6d945f..4ae42e8 100755 --- a/scripts/update-qt5-modules.sh +++ b/scripts/update-qt5-modules.sh | |||
@@ -53,9 +53,8 @@ for S in $SHA1S; do | |||
53 | elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then | 53 | elif [ "${PROJECT}" = "qtlocation/src/3rdparty/mapbox-gl-native" ]; then |
54 | sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* | 54 | sed -i -e "/^SRCREV_qtlocation-mapboxgl/s/\".*\"/\"${SHA1}\"/" qtlocation_git.bb* |
55 | echo "qtlocation (mapboxgl) -> ${SHA1}" | 55 | echo "qtlocation (mapboxgl) -> ${SHA1}" |
56 | elif [ "${PROJECT}" = "tqtc-qmlcompiler" ] && [ -e "qtquickcompiler_git.bb" ]; then | 56 | elif [ "${PROJECT}" = "qtenginio" ] || [ "${PROJECT}" = "qtquick1" ] || [ "${PROJECT}" = "qtsystems" ]; then |
57 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" qtquickcompiler_git.bb | 57 | echo "${PROJECT} -> ignored" |
58 | echo "qtquickcompiler -> ${SHA1}" | ||
59 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then | 58 | elif [ "$(echo *${PROJECT}*_git.bb*)" != "*${PROJECT}*_git.bb*" ]; then |
60 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* | 59 | sed -i -e "/^SRCREV/s/\".*\"/\"${SHA1}\"/" *${PROJECT}*_git.bb* |
61 | echo "${PROJECT} -> ${SHA1}" | 60 | echo "${PROJECT} -> ${SHA1}" |