diff options
author | Florian Wühr <f.wuehr@rational-online.com> | 2023-05-15 11:50:42 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-16 08:04:20 -0700 |
commit | 8acc0b9c2a3942077d43f0baefc2841cc993fae1 (patch) | |
tree | 2f3df42b6c84ec881e70aba565dd8e30adb88908 | |
parent | 8558c4c27c74b477e6f5fcf4355e87235efbeed7 (diff) | |
download | meta-clang-8acc0b9c2a3942077d43f0baefc2841cc993fae1.tar.gz |
compiler-rt-sanitizers: allow tsan to be built since clang 12 works by
default
-rw-r--r-- | recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch | 40 | ||||
-rw-r--r-- | recipes-devtools/clang/common.inc | 1 |
2 files changed, 0 insertions, 41 deletions
diff --git a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch b/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch deleted file mode 100644 index 97d57c2..0000000 --- a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 121a71a3923dbace24dbb7bd25f9f286fb9f91fb Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 18 Jul 2016 08:05:02 +0000 | ||
4 | Subject: [PATCH] compiler-rt: Disable tsan on OE/glibc | ||
5 | |||
6 | It does not build see | ||
7 | http://lists.llvm.org/pipermail/llvm-dev/2016-July/102235.html | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | compiler-rt/cmake/config-ix.cmake | 2 +- | ||
12 | compiler-rt/test/sanitizer_common/CMakeLists.txt | 2 +- | ||
13 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/compiler-rt/cmake/config-ix.cmake b/compiler-rt/cmake/config-ix.cmake | ||
16 | index f81b8384cbd5..196aa62fd01c 100644 | ||
17 | --- a/compiler-rt/cmake/config-ix.cmake | ||
18 | +++ b/compiler-rt/cmake/config-ix.cmake | ||
19 | @@ -723,7 +723,7 @@ else() | ||
20 | endif() | ||
21 | |||
22 | if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND | ||
23 | - OS_NAME MATCHES "Darwin|Linux|FreeBSD|Android|NetBSD") | ||
24 | + OS_NAME MATCHES "Darwin|FreeBSD|Android|NetBSD") | ||
25 | set(COMPILER_RT_HAS_TSAN TRUE) | ||
26 | else() | ||
27 | set(COMPILER_RT_HAS_TSAN FALSE) | ||
28 | diff --git a/compiler-rt/test/sanitizer_common/CMakeLists.txt b/compiler-rt/test/sanitizer_common/CMakeLists.txt | ||
29 | index 7f1b0f257716..2caf78be2511 100644 | ||
30 | --- a/compiler-rt/test/sanitizer_common/CMakeLists.txt | ||
31 | +++ b/compiler-rt/test/sanitizer_common/CMakeLists.txt | ||
32 | @@ -11,7 +11,7 @@ set(SANITIZER_COMMON_TESTSUITES) | ||
33 | # FIXME(dliew): We should switch to COMPILER_RT_SANITIZERS_TO_BUILD instead of | ||
34 | # the hard coded `SUPPORTED_TOOLS_INIT` list once we know that the other | ||
35 | # sanitizers work. | ||
36 | -set(SUPPORTED_TOOLS_INIT asan lsan msan tsan ubsan) | ||
37 | +set(SUPPORTED_TOOLS_INIT asan lsan msan ubsan) | ||
38 | set(SUPPORTED_TOOLS) | ||
39 | foreach(SANITIZER_TOOL ${SUPPORTED_TOOLS_INIT}) | ||
40 | string(TOUPPER ${SANITIZER_TOOL} SANITIZER_TOOL_UPPER) | ||
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc index 6cedf4d..ed3c2c0 100644 --- a/recipes-devtools/clang/common.inc +++ b/recipes-devtools/clang/common.inc | |||
@@ -13,7 +13,6 @@ SRC_URI = "\ | |||
13 | file://0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch \ | 13 | file://0002-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch \ |
14 | file://0003-compiler-rt-support-a-new-embedded-linux-target.patch \ | 14 | file://0003-compiler-rt-support-a-new-embedded-linux-target.patch \ |
15 | file://0004-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch \ | 15 | file://0004-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch \ |
16 | file://0005-compiler-rt-Disable-tsan-on-OE-glibc.patch \ | ||
17 | file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \ | 16 | file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \ |
18 | file://0007-llvm-allow-env-override-of-exe-path.patch \ | 17 | file://0007-llvm-allow-env-override-of-exe-path.patch \ |
19 | file://0008-clang-driver-Check-sysroot-for-ldso-path.patch \ | 18 | file://0008-clang-driver-Check-sysroot-for-ldso-path.patch \ |