diff options
author | Esben Haabendal <esben.haabendal@huawei.com> | 2022-04-07 14:32:43 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-08 09:08:54 -0700 |
commit | 4c579d445088a40ef1b3ce7c1f961ed5c845c292 (patch) | |
tree | 310d20f3aebaa5d8e157a273381225635f266e15 | |
parent | d0a0b0f414bee2b89881064f844a1f2df535a7ad (diff) | |
download | meta-clang-4c579d445088a40ef1b3ce7c1f961ed5c845c292.tar.gz |
compiler-rt: Fix nativesdk building
Signed-off-by: Esben Haabendal <esben.haabendal@huawei.com>
(cherry picked from commit f3c3e492285b57b269916b795b2e8b8767eb6179)
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 5d991bb..552c6f7 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -22,9 +22,14 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
22 | 22 | ||
23 | DEPENDS += "ninja-native libgcc" | 23 | DEPENDS += "ninja-native libgcc" |
24 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc gcc-runtime" | 24 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc gcc-runtime" |
25 | DEPENDS:append:class-nativesdk = " clang-native" | 25 | DEPENDS:append:class-nativesdk = " clang-native clang-crosssdk-${SDK_ARCH} nativesdk-gcc-runtime" |
26 | DEPENDS:append:class-native = " clang-native" | 26 | DEPENDS:append:class-native = " clang-native" |
27 | 27 | ||
28 | # Trick clang.bbclass into not creating circular dependencies | ||
29 | UNWINDLIB:class-nativesdk = "--unwindlib=libgcc" | ||
30 | COMPILER_RT:class-nativesdk:toolchain-clang:runtime-llvm = "-rtlib=libgcc --unwindlib=libgcc" | ||
31 | LIBCPLUSPLUS:class-nativesdk:toolchain-clang:runtime-llvm = "-stdlib=libstdc++" | ||
32 | |||
28 | CXXFLAGS += "-stdlib=libstdc++" | 33 | CXXFLAGS += "-stdlib=libstdc++" |
29 | LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" | 34 | LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" |
30 | BUILD_CXXFLAGS += "-stdlib=libstdc++" | 35 | BUILD_CXXFLAGS += "-stdlib=libstdc++" |