summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-07-04 16:53:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-07-08 17:39:55 -0700
commit2ed384c64e206016c628451672c688e59944381b (patch)
tree8332bba77fd4e739505de49c5d2ceca70a88f84e
parent557663d9e9fa34fa2b860696ce5a5d8744ade8f6 (diff)
downloadmeta-clang-2ed384c64e206016c628451672c688e59944381b.tar.gz
libcxx: Do not induce -mbranch-protection externally on arm64
On arm64 OE-Core has moved the gcc default configuration done with --enable-standard-branch-protection to be a CFLAGS option which is appended to CC variable, this means that this option can override the package's default to not use it e.g. libunwind where the library has to be built without it. Fixes https://github.com/kraj/meta-clang/issues/963 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
-rw-r--r--recipes-devtools/clang/libcxx_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index b8df601..b0c227f 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -41,6 +41,7 @@ BUILD_CXXFLAGS += "-stdlib=libstdc++"
41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" 41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++"
42BUILD_CPPFLAGS:remove = "-stdlib=libc++" 42BUILD_CPPFLAGS:remove = "-stdlib=libc++"
43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi" 43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi"
44TUNE_CCARGS:remove = "-mbranch-protection=standard"
44 45
45INHIBIT_DEFAULT_DEPS = "1" 46INHIBIT_DEFAULT_DEPS = "1"
46 47