summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-07-28 09:24:26 -0700
committerKhem Raj <raj.khem@gmail.com>2022-11-04 13:34:12 -0700
commit5d6c7c189e4abdfc3e4b309f7edadcbddb9236eb (patch)
tree7d2dfa6f7ec09f072db571b19fa0428559b1946b
parented5ac4ff7a8d3704f2d2fe9db659304d1b360e2c (diff)
downloadmeta-clang-5d6c7c189e4abdfc3e4b309f7edadcbddb9236eb.tar.gz
clang: Add compiler-rt and libcxx to build time depends for target
These are not staged into sysroot otherwise and cmake fails to configure Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/clang_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index 1ff8f81..65c280c 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -193,7 +193,7 @@ EXTRA_OECMAKE:append:class-target = "\
193 193
194DEPENDS = "binutils zlib libffi libxml2 libxml2-native ninja-native swig-native" 194DEPENDS = "binutils zlib libffi libxml2 libxml2-native ninja-native swig-native"
195DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_ARCH} virtual/${TARGET_PREFIX}binutils-crosssdk nativesdk-python3" 195DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_ARCH} virtual/${TARGET_PREFIX}binutils-crosssdk nativesdk-python3"
196DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} python3" 196DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} python3 compiler-rt libcxx"
197 197
198RRECOMMENDS:${PN} = "binutils" 198RRECOMMENDS:${PN} = "binutils"
199RRECOMMENDS:${PN}:append:class-target = " libcxx-dev" 199RRECOMMENDS:${PN}:append:class-target = " libcxx-dev"