summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Dorniak <jaskij@gmail.com>2022-12-19 05:27:18 +0100
committerKhem Raj <raj.khem@gmail.com>2022-12-26 17:41:10 -0800
commitbc8388c622c62cde24512d5b4473ede1f5710348 (patch)
tree2e3733c21485d21d7e2c7ab856cb255af15e9279
parent299a5fd24b7bee2191127c9fef8bd39d807f3492 (diff)
downloadmeta-clang-bc8388c622c62cde24512d5b4473ede1f5710348.tar.gz
Fix OpenMP builds with thin LTO enabled.
When built with thin LTO enabled, LLVM produces object files containing LLVM IR, which ld can't understand. Since we're forcing the toolchain to clang anyway, let's also force using lld. Fixes GitHub #708 Signed-off-by: Jan Dorniak <jaskij@gmail.com>
-rw-r--r--recipes-devtools/clang/openmp_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index f19954a..241aeb6 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -12,6 +12,8 @@ TOOLCHAIN = "clang"
12 12
13LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" 13LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79"
14 14
15LDFLAGS:append = " -fuse-ld=lld"
16
15inherit cmake pkgconfig perlnative 17inherit cmake pkgconfig perlnative
16 18
17DEPENDS += "elfutils libffi clang" 19DEPENDS += "elfutils libffi clang"