summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-07-04 16:53:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-07-15 08:24:51 -0700
commitdf21b1563910c80d7e2964971b7c5b79b5186922 (patch)
tree8447ac985c4fba5bd8386c5484ac817e76c6bbf5
parent0acff283249842eb1f617b20c2ed4ebf9f8e3557 (diff)
downloadmeta-clang-df21b1563910c80d7e2964971b7c5b79b5186922.tar.gz
libcxx: Do not induce -mbranch-protection externally on arm64
On arm64 OE-Core has moved the gcc default configuration done with --enable-standard-branch-protection to be a CFLAGS option which is appended to CC variable, this means that this option can override the package's default to not use it e.g. libunwind where the library has to be built without it. Fixes https://github.com/kraj/meta-clang/issues/963 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
-rw-r--r--recipes-devtools/clang/libcxx_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 9d4f033..a6f2e66 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -41,6 +41,7 @@ BUILD_CXXFLAGS += "-stdlib=libstdc++"
41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" 41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++"
42BUILD_CPPFLAGS:remove = "-stdlib=libc++" 42BUILD_CPPFLAGS:remove = "-stdlib=libc++"
43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi" 43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi"
44TUNE_CCARGS:remove = "-mbranch-protection=standard"
44 45
45INHIBIT_DEFAULT_DEPS = "1" 46INHIBIT_DEFAULT_DEPS = "1"
46 47