diff options
author | Zoltán Böszörményi <zboszor@gmail.com> | 2023-03-08 06:59:05 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-08 13:21:05 -0800 |
commit | 296bf4b6b94847d55fbded746670b2b279d28bd2 (patch) | |
tree | f887ba1d65f092a37f5ae5bd01821a75d8d6cfc3 | |
parent | 3237e56acab832434d30caf36c65fc860e8778f1 (diff) | |
download | meta-clang-296bf4b6b94847d55fbded746670b2b279d28bd2.tar.gz |
bindgen-cli: Add the build dependency crate:// links
"inherit cargo-update-recipe-crates" was misunderstood, as in
that it doesn't add the build dependencies transparently
during the build. Instead, "bitbake -c update_crates recipe-name"
must be run and the resulting recipe-name-crates.inc file
must be included in the recipe.
Update the recipe with using the crate:// link for bindgen-cli.
Otherwise "bitbake -c update_crates recipe-name" got confused
and produced empty output when using the source in a subdirectory
from the rust-bindgen GIT repo.
Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
-rw-r--r-- | recipes-devtools/bindgen-cli/bindgen-cli-crates.inc | 67 | ||||
-rw-r--r-- | recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb | 10 |
2 files changed, 70 insertions, 7 deletions
diff --git a/recipes-devtools/bindgen-cli/bindgen-cli-crates.inc b/recipes-devtools/bindgen-cli/bindgen-cli-crates.inc new file mode 100644 index 0000000..009d415 --- /dev/null +++ b/recipes-devtools/bindgen-cli/bindgen-cli-crates.inc | |||
@@ -0,0 +1,67 @@ | |||
1 | # Autogenerated with 'bitbake -c update_crates bindgen-cli' | ||
2 | |||
3 | # from Cargo.lock | ||
4 | SRC_URI += " \ | ||
5 | crate://crates.io/aho-corasick/0.7.20 \ | ||
6 | crate://crates.io/atty/0.2.14 \ | ||
7 | crate://crates.io/bindgen/0.64.0 \ | ||
8 | crate://crates.io/bitflags/1.3.2 \ | ||
9 | crate://crates.io/cc/1.0.79 \ | ||
10 | crate://crates.io/cexpr/0.6.0 \ | ||
11 | crate://crates.io/cfg-if/1.0.0 \ | ||
12 | crate://crates.io/clang-sys/1.4.0 \ | ||
13 | crate://crates.io/clap/4.1.4 \ | ||
14 | crate://crates.io/clap_derive/4.1.0 \ | ||
15 | crate://crates.io/clap_lex/0.3.1 \ | ||
16 | crate://crates.io/either/1.8.1 \ | ||
17 | crate://crates.io/env_logger/0.9.3 \ | ||
18 | crate://crates.io/errno/0.2.8 \ | ||
19 | crate://crates.io/errno-dragonfly/0.1.2 \ | ||
20 | crate://crates.io/glob/0.3.1 \ | ||
21 | crate://crates.io/heck/0.4.1 \ | ||
22 | crate://crates.io/hermit-abi/0.1.19 \ | ||
23 | crate://crates.io/hermit-abi/0.3.0 \ | ||
24 | crate://crates.io/humantime/2.1.0 \ | ||
25 | crate://crates.io/io-lifetimes/1.0.5 \ | ||
26 | crate://crates.io/is-terminal/0.4.3 \ | ||
27 | crate://crates.io/lazy_static/1.4.0 \ | ||
28 | crate://crates.io/lazycell/1.3.0 \ | ||
29 | crate://crates.io/libc/0.2.139 \ | ||
30 | crate://crates.io/libloading/0.7.4 \ | ||
31 | crate://crates.io/linux-raw-sys/0.1.4 \ | ||
32 | crate://crates.io/log/0.4.17 \ | ||
33 | crate://crates.io/memchr/2.5.0 \ | ||
34 | crate://crates.io/minimal-lexical/0.2.1 \ | ||
35 | crate://crates.io/nom/7.1.3 \ | ||
36 | crate://crates.io/once_cell/1.17.0 \ | ||
37 | crate://crates.io/os_str_bytes/6.4.1 \ | ||
38 | crate://crates.io/peeking_take_while/0.1.2 \ | ||
39 | crate://crates.io/proc-macro-error/1.0.4 \ | ||
40 | crate://crates.io/proc-macro-error-attr/1.0.4 \ | ||
41 | crate://crates.io/proc-macro2/1.0.51 \ | ||
42 | crate://crates.io/quote/1.0.23 \ | ||
43 | crate://crates.io/regex/1.7.1 \ | ||
44 | crate://crates.io/regex-syntax/0.6.28 \ | ||
45 | crate://crates.io/rustc-hash/1.1.0 \ | ||
46 | crate://crates.io/rustix/0.36.8 \ | ||
47 | crate://crates.io/shlex/1.1.0 \ | ||
48 | crate://crates.io/strsim/0.10.0 \ | ||
49 | crate://crates.io/syn/1.0.107 \ | ||
50 | crate://crates.io/termcolor/1.2.0 \ | ||
51 | crate://crates.io/unicode-ident/1.0.6 \ | ||
52 | crate://crates.io/version_check/0.9.4 \ | ||
53 | crate://crates.io/which/4.4.0 \ | ||
54 | crate://crates.io/winapi/0.3.9 \ | ||
55 | crate://crates.io/winapi-i686-pc-windows-gnu/0.4.0 \ | ||
56 | crate://crates.io/winapi-util/0.1.5 \ | ||
57 | crate://crates.io/winapi-x86_64-pc-windows-gnu/0.4.0 \ | ||
58 | crate://crates.io/windows-sys/0.45.0 \ | ||
59 | crate://crates.io/windows-targets/0.42.1 \ | ||
60 | crate://crates.io/windows_aarch64_gnullvm/0.42.1 \ | ||
61 | crate://crates.io/windows_aarch64_msvc/0.42.1 \ | ||
62 | crate://crates.io/windows_i686_gnu/0.42.1 \ | ||
63 | crate://crates.io/windows_i686_msvc/0.42.1 \ | ||
64 | crate://crates.io/windows_x86_64_gnu/0.42.1 \ | ||
65 | crate://crates.io/windows_x86_64_gnullvm/0.42.1 \ | ||
66 | crate://crates.io/windows_x86_64_msvc/0.42.1 \ | ||
67 | " | ||
diff --git a/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb b/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb index 6f66549..80723ef 100644 --- a/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb +++ b/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb | |||
@@ -2,17 +2,13 @@ SUMMARY = "Automatically generates Rust FFI bindings to C and C++ libraries." | |||
2 | HOMEPAGE = "https://rust-lang.github.io/rust-bindgen/" | 2 | HOMEPAGE = "https://rust-lang.github.io/rust-bindgen/" |
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://bindgen-cli/LICENSE;md5=0b9a98cb3dcdefcceb145324693fda9b" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0b9a98cb3dcdefcceb145324693fda9b" |
6 | 6 | ||
7 | inherit rust cargo cargo-update-recipe-crates | 7 | inherit rust cargo cargo-update-recipe-crates |
8 | 8 | ||
9 | SRC_URI = "git://github.com/rust-lang/rust-bindgen.git;protocol=https;nobranch=1;branch=main" | 9 | SRC_URI = "crate://crates.io/${BPN}/${PV}" |
10 | SRCREV = "ae6817256ac557981906e93a1f866349db85053e" | ||
11 | 10 | ||
12 | S = "${WORKDIR}/git" | 11 | require ${BPN}-crates.inc |
13 | |||
14 | CARGO_SRC_DIR = "bindgen-cli" | ||
15 | CARGO_LOCK_SRC_DIR = "bindgen-cli" | ||
16 | 12 | ||
17 | do_install:append:class-native() { | 13 | do_install:append:class-native() { |
18 | create_wrapper ${D}/${bindir}/bindgen LIBCLANG_PATH="${STAGING_LIBDIR_NATIVE}" | 14 | create_wrapper ${D}/${bindir}/bindgen LIBCLANG_PATH="${STAGING_LIBDIR_NATIVE}" |