diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-02-05 12:52:14 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-10 00:47:02 -0800 |
commit | 95a45c8947ef8978a6d1a7568ee7bb3c6a6cf77e (patch) | |
tree | e7d114f445d940587575d45a0e1699d6e56e1453 | |
parent | 552b6a3849d80ddc2878cd9e9438b81549a9b3af (diff) | |
download | meta-clang-95a45c8947ef8978a6d1a7568ee7bb3c6a6cf77e.tar.gz |
openmp: Provide missing tools during cross compile
Enable ompd gdb plugin build and add py3 to depndencies as it is
required by the plugin
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-devtools/clang/openmp_git.bb | 11 |
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb index 60efcaf..3611210 100644 --- a/recipes-devtools/clang/openmp_git.bb +++ b/recipes-devtools/clang/openmp_git.bb | |||
@@ -12,7 +12,7 @@ TOOLCHAIN = "clang" | |||
12 | 12 | ||
13 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" | 13 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" |
14 | 14 | ||
15 | inherit cmake pkgconfig perlnative | 15 | inherit cmake pkgconfig perlnative python3native |
16 | 16 | ||
17 | DEPENDS += "elfutils libffi clang" | 17 | DEPENDS += "elfutils libffi clang" |
18 | 18 | ||
@@ -23,6 +23,9 @@ EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RelWithDebInfo \ | |||
23 | -DCLANG_TOOL=${STAGING_BINDIR_NATIVE}/clang \ | 23 | -DCLANG_TOOL=${STAGING_BINDIR_NATIVE}/clang \ |
24 | -DLINK_TOOL=${STAGING_BINDIR_NATIVE}/llvm-link \ | 24 | -DLINK_TOOL=${STAGING_BINDIR_NATIVE}/llvm-link \ |
25 | -DOPT_TOOL=${STAGING_BINDIR_NATIVE}/opt \ | 25 | -DOPT_TOOL=${STAGING_BINDIR_NATIVE}/opt \ |
26 | -DOPENMP_LLVM_LIT_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-lit \ | ||
27 | -DEXTRACT_TOOL=${STAGING_BINDIR_NATIVE}/llvm-extract \ | ||
28 | -DPACKAGER_TOOL=${STAGING_BINDIR_NATIVE}/clang-offload-packager \ | ||
26 | -DCMAKE_POSITION_INDEPENDENT_CODE=ON \ | 29 | -DCMAKE_POSITION_INDEPENDENT_CODE=ON \ |
27 | " | 30 | " |
28 | 31 | ||
@@ -40,10 +43,14 @@ PACKAGECONFIG[aliases] = "-DLIBOMP_INSTALL_ALIASES=ON,-DLIBOMP_INSTALL_ALIASES=O | |||
40 | PACKAGECONFIG[offloading-plugin] = ",,elfutils libffi,libelf libffi" | 43 | PACKAGECONFIG[offloading-plugin] = ",,elfutils libffi,libelf libffi" |
41 | PACKAGECONFIG[no-atomics] = "-DLIBOMP_HAVE_BUILTIN_ATOMIC=OFF -DLIBOMP_LIBFLAGS='-latomic',," | 44 | PACKAGECONFIG[no-atomics] = "-DLIBOMP_HAVE_BUILTIN_ATOMIC=OFF -DLIBOMP_LIBFLAGS='-latomic',," |
42 | 45 | ||
43 | PACKAGES += "${PN}-libomptarget" | 46 | PACKAGES += "${PN}-libomptarget ${PN}-gdb-plugin" |
44 | FILES_SOLIBSDEV = "" | 47 | FILES_SOLIBSDEV = "" |
45 | FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}" | 48 | FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}" |
46 | FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc" | 49 | FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc" |
50 | FILES:${PN}-gdb-plugin = "${datadir}/gdb/python/ompd" | ||
51 | |||
52 | RDEPENDS:${PN}-gdb-plugin += "python3-core" | ||
53 | |||
47 | INSANE_SKIP:${PN} = "dev-so" | 54 | INSANE_SKIP:${PN} = "dev-so" |
48 | # Currently the static libraries contain buildpaths | 55 | # Currently the static libraries contain buildpaths |
49 | INSANE_SKIP:${PN}-staticdev += "buildpaths" | 56 | INSANE_SKIP:${PN}-staticdev += "buildpaths" |