summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2024-07-08 15:53:37 +0800
committerKhem Raj <raj.khem@gmail.com>2024-07-08 17:39:23 -0700
commit0c2b19b7ad03bba7c21b6bf111ba1a118ea9d44a (patch)
treebab2414862264f8375a8793a0cbc408b6d6b5e6d
parentee218b7bc9c4b43d66e56c9cde5405318d8d5deb (diff)
downloadmeta-clang-0c2b19b7ad03bba7c21b6bf111ba1a118ea9d44a.tar.gz
recipes-devtools/llvm/llvm_%.bbappend: fix the build of bpftrace ptest failed
Due to commit [1][2], llvm-native was added to bpftrace to provide llvm-objcopy for the ptest. But because of commit [3], llvm-native requires opengl in DISTRO_FEATURES to support libllvm. In order to make the build of bpftrace ptest work, explicitly add libllvm to PACKAGECONFIG for llvm-native if ptest enabled. According to [2][3], bpftrace used llvm-objcopy to generate BTF data for unit tests, regardless opengl in DISTRO_FEATURES, enable accelerated software renderer or not does not have side effect on bpftrace [1] https://github.com/kraj/meta-clang/commit/bf6c02a47fb2ffec735df6c7dd642432f3681337 [2] https://github.com/bpftrace/bpftrace/commit/6cc531e35cd3bf77aa2a30cef3e3481c9c53042e [3] https://git.openembedded.org/openembedded-core/commit/?id=ec22bfa67f6f1766102501d4593ce29aafe8c166 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-rw-r--r--recipes-devtools/llvm/llvm_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/llvm/llvm_%.bbappend b/recipes-devtools/llvm/llvm_%.bbappend
new file mode 100644
index 0000000..116aba2
--- /dev/null
+++ b/recipes-devtools/llvm/llvm_%.bbappend
@@ -0,0 +1 @@
PACKAGECONFIG:append:class-native = " ${@bb.utils.contains('PTEST_ENABLED', '1', 'libllvm', '', d)}"