summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-07-04 16:53:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-07-04 23:38:07 -0700
commit96b2f3da50c8cf814f661fba37df0a098457b016 (patch)
tree2b254979e0b79a84606d7ffa9ab342a1f5214a80
parentef95030ad03800262ec9798357de68e137a1c5c0 (diff)
downloadmeta-clang-96b2f3da50c8cf814f661fba37df0a098457b016.tar.gz
libcxx: Do not induce -mbranch-protection externally on arm64
On arm64 OE-Core has moved the gcc default configuration done with --enable-standard-branch-protection to be a CFLAGS option which is appended to CC variable, this means that this option can override the package's default to not use it e.g. libunwind where the library has to be built without it. Fixes https://github.com/kraj/meta-clang/issues/963 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/libcxx_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index b0a2f2e..280f3d6 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -41,6 +41,7 @@ BUILD_CXXFLAGS += "-stdlib=libstdc++"
41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" 41BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++"
42BUILD_CPPFLAGS:remove = "-stdlib=libc++" 42BUILD_CPPFLAGS:remove = "-stdlib=libc++"
43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi" 43BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi"
44TUNE_CCARGS:remove = "-mbranch-protection=standard"
44 45
45INHIBIT_DEFAULT_DEPS = "1" 46INHIBIT_DEFAULT_DEPS = "1"
46 47