diff options
-rw-r--r-- | recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch | 26 | ||||
-rw-r--r-- | recipes-devtools/clang/common.inc | 1 |
2 files changed, 1 insertions, 26 deletions
diff --git a/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch deleted file mode 100644 index 3901268..0000000 --- a/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 11bd98436bd7e99fb1fc2c07c150c71e2250a262 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joel Winarske <joel.winarske@gmail.com> | ||
3 | Date: Wed, 9 Feb 2022 11:11:55 -0800 | ||
4 | Subject: [PATCH] OpenMP link fix | ||
5 | |||
6 | Signed-off-by: Joel Winarske <joel.winarske@gmail.com> | ||
7 | --- | ||
8 | openmp/runtime/src/CMakeLists.txt | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt | ||
12 | index 9f46b4bd4..3106e497d 100644 | ||
13 | --- a/openmp/runtime/src/CMakeLists.txt | ||
14 | +++ b/openmp/runtime/src/CMakeLists.txt | ||
15 | @@ -168,7 +168,7 @@ endif() | ||
16 | |||
17 | # Linking command will include libraries in LIBOMP_CONFIGURED_LIBFLAGS | ||
18 | libomp_get_libflags(LIBOMP_CONFIGURED_LIBFLAGS) | ||
19 | -target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS}) | ||
20 | +target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS} "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exports_so.txt") | ||
21 | |||
22 | # Create *.inc before compiling any sources | ||
23 | # objects depend on : .inc files | ||
24 | -- | ||
25 | 2.31.1 | ||
26 | |||
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc index c94dd69..e211258 100644 --- a/recipes-devtools/clang/common.inc +++ b/recipes-devtools/clang/common.inc | |||
@@ -25,6 +25,7 @@ SRC_URI = "\ | |||
25 | file://0014-clang-Fix-ldso-for-musl-on-x86-and-x32-architectures.patch \ | 25 | file://0014-clang-Fix-ldso-for-musl-on-x86-and-x32-architectures.patch \ |
26 | file://0015-clang-scan-view-needs-python-2.x.patch \ | 26 | file://0015-clang-scan-view-needs-python-2.x.patch \ |
27 | file://0016-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \ | 27 | file://0016-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \ |
28 | file://0017-Pass-PYTHON_EXECUTABLE-when-cross-compiling-for-nati.patch \ | ||
28 | file://0018-Check-for-atomic-double-intrinsics.patch \ | 29 | file://0018-Check-for-atomic-double-intrinsics.patch \ |
29 | file://0019-clang-Enable-SSP-and-PIE-by-default.patch \ | 30 | file://0019-clang-Enable-SSP-and-PIE-by-default.patch \ |
30 | file://0020-libcxx-Add-compiler-runtime-library-to-link-step-for.patch \ | 31 | file://0020-libcxx-Add-compiler-runtime-library-to-link-step-for.patch \ |