diff options
-rw-r--r-- | conf/nonclangable.conf | 2 | ||||
-rw-r--r-- | recipes-kernel/lttng/babeltrace2/babeltrace2-2.0.2-fix-reserved-keywords.patch | 31 | ||||
-rw-r--r-- | recipes-kernel/lttng/babeltrace2_%.bbappend | 2 |
3 files changed, 33 insertions, 2 deletions
diff --git a/conf/nonclangable.conf b/conf/nonclangable.conf index aa17df8..f92a066 100644 --- a/conf/nonclangable.conf +++ b/conf/nonclangable.conf | |||
@@ -1,5 +1,3 @@ | |||
1 | #babeltrace2: ELF binary /usr/lib/babeltrace2/plugins/babeltrace-plugin-text.so has relocations in .text [textrel] | ||
2 | TOOLCHAIN_pn-babeltrace2 = "gcc" | ||
3 | TOOLCHAIN_pn-u-boot = "gcc" | 1 | TOOLCHAIN_pn-u-boot = "gcc" |
4 | TOOLCHAIN_pn-cpufrequtils = "gcc" | 2 | TOOLCHAIN_pn-cpufrequtils = "gcc" |
5 | # crash embeds version of gdb which is not buildable with clang | 3 | # crash embeds version of gdb which is not buildable with clang |
diff --git a/recipes-kernel/lttng/babeltrace2/babeltrace2-2.0.2-fix-reserved-keywords.patch b/recipes-kernel/lttng/babeltrace2/babeltrace2-2.0.2-fix-reserved-keywords.patch new file mode 100644 index 0000000..43461fe --- /dev/null +++ b/recipes-kernel/lttng/babeltrace2/babeltrace2-2.0.2-fix-reserved-keywords.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 790d3e55982df7b21caea7eff97dbd0ebce4f8cd Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch> | ||
3 | Date: Wed, 26 May 2021 05:06:55 +0200 | ||
4 | Subject: [PATCH] ctf-writer: Fix list of reserved keywords | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | The missing comma between "void" and "_Bool" causes the compiler to | ||
10 | treat it as one string ("void_Bool"), missing both "void" and "_Bool" | ||
11 | as real reserved keywords. | ||
12 | |||
13 | Signed-off-by: Bernhard Rosenkränzer <bero@lindev.ch> | ||
14 | Upstream-Status: Submitted [https://github.com/efficios/babeltrace/pull/117] | ||
15 | --- | ||
16 | src/ctf-writer/utils.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/ctf-writer/utils.c b/src/ctf-writer/utils.c | ||
20 | index 0cfb5742b..6c4b0ed8f 100644 | ||
21 | --- a/src/ctf-writer/utils.c | ||
22 | +++ b/src/ctf-writer/utils.c | ||
23 | @@ -25,7 +25,7 @@ const char * const reserved_keywords_str[] = {"align", "callsite", | ||
24 | "const", "char", "clock", "double", "enum", "env", "event", | ||
25 | "floating_point", "float", "integer", "int", "long", "short", "signed", | ||
26 | "stream", "string", "struct", "trace", "typealias", "typedef", | ||
27 | - "unsigned", "variant", "void" "_Bool", "_Complex", "_Imaginary"}; | ||
28 | + "unsigned", "variant", "void", "_Bool", "_Complex", "_Imaginary"}; | ||
29 | |||
30 | static GHashTable *reserved_keywords_set; | ||
31 | static int init_done; | ||
diff --git a/recipes-kernel/lttng/babeltrace2_%.bbappend b/recipes-kernel/lttng/babeltrace2_%.bbappend new file mode 100644 index 0000000..3f2f08b --- /dev/null +++ b/recipes-kernel/lttng/babeltrace2_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | SRC_URI_append = " file://babeltrace2-2.0.2-fix-reserved-keywords.patch" | ||