diff options
-rw-r--r-- | recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch | 26 | ||||
-rw-r--r-- | recipes-devtools/clang/openmp_git.bb | 4 |
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch new file mode 100644 index 0000000..3901268 --- /dev/null +++ b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 11bd98436bd7e99fb1fc2c07c150c71e2250a262 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joel Winarske <joel.winarske@gmail.com> | ||
3 | Date: Wed, 9 Feb 2022 11:11:55 -0800 | ||
4 | Subject: [PATCH] OpenMP link fix | ||
5 | |||
6 | Signed-off-by: Joel Winarske <joel.winarske@gmail.com> | ||
7 | --- | ||
8 | openmp/runtime/src/CMakeLists.txt | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt | ||
12 | index 9f46b4bd4..3106e497d 100644 | ||
13 | --- a/openmp/runtime/src/CMakeLists.txt | ||
14 | +++ b/openmp/runtime/src/CMakeLists.txt | ||
15 | @@ -168,7 +168,7 @@ endif() | ||
16 | |||
17 | # Linking command will include libraries in LIBOMP_CONFIGURED_LIBFLAGS | ||
18 | libomp_get_libflags(LIBOMP_CONFIGURED_LIBFLAGS) | ||
19 | -target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS}) | ||
20 | +target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS} "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exports_so.txt") | ||
21 | |||
22 | # Create *.inc before compiling any sources | ||
23 | # objects depend on : .inc files | ||
24 | -- | ||
25 | 2.31.1 | ||
26 | |||
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb index a1fa3b1..2a366bc 100644 --- a/recipes-devtools/clang/openmp_git.bb +++ b/recipes-devtools/clang/openmp_git.bb | |||
@@ -12,6 +12,10 @@ TOOLCHAIN = "clang" | |||
12 | 12 | ||
13 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79" | 13 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79" |
14 | 14 | ||
15 | SRC_URI += "\ | ||
16 | file://0029-OpenMP-link-fix.patch \ | ||
17 | " | ||
18 | |||
15 | inherit cmake pkgconfig perlnative | 19 | inherit cmake pkgconfig perlnative |
16 | 20 | ||
17 | DEPENDS += "elfutils libffi" | 21 | DEPENDS += "elfutils libffi" |