summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/clang/clang/0040-Install-arm_neon_sve_bridge.h.patch44
-rw-r--r--recipes-devtools/clang/common.inc1
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0040-Install-arm_neon_sve_bridge.h.patch b/recipes-devtools/clang/clang/0040-Install-arm_neon_sve_bridge.h.patch
new file mode 100644
index 0000000..2bdeed8
--- /dev/null
+++ b/recipes-devtools/clang/clang/0040-Install-arm_neon_sve_bridge.h.patch
@@ -0,0 +1,44 @@
1From c65c188643e963a857ca0d58a4b53529f8e98651 Mon Sep 17 00:00:00 2001
2From: Gyorgy Sarvari <skandigraun@gmail.com>
3Date: Fri, 7 Feb 2025 20:48:54 +0100
4Subject: [PATCH] [AArch64] Install arm_neon_sve_bridge.h
5
6arm_neon_sve_bridge.h is not generated, so the rules which ensure the
7generated files get copied into the installation prefix don't apply to
8this one.
9
10Add it to the base file set instead, which ensures it ends up
11both in the build directory and the installation directory.
12
13The original upstream patch needed to be adapted to version 14.0.6.
14
15Signed-off-by: Gyorgy Sarvari <skandigraun@gmail.com>
16
17Upstream-Status: Backport [https://github.com/llvm/llvm-project/commit/8cb9e3c3ce1e7e1658921f90420b68ca16bb98fc]
18---
19 clang/lib/Headers/CMakeLists.txt | 5 +----
20 1 file changed, 1 insertion(+), 4 deletions(-)
21
22diff --git a/clang/lib/Headers/CMakeLists.txt b/clang/lib/Headers/CMakeLists.txt
23index 078988980c52..5fa7310427c6 100644
24--- a/clang/lib/Headers/CMakeLists.txt
25+++ b/clang/lib/Headers/CMakeLists.txt
26@@ -7,6 +7,7 @@ set(files
27 arm_cmse.h
28 armintr.h
29 arm64intr.h
30+ arm_neon_sve_bridge.h
31 avx2intrin.h
32 avx512bf16intrin.h
33 avx512bwintrin.h
34@@ -219,10 +220,6 @@ if(ARM IN_LIST LLVM_TARGETS_TO_BUILD OR AArch64 IN_LIST LLVM_TARGETS_TO_BUILD)
35 clang_generate_header(-gen-arm-mve-header arm_mve.td arm_mve.h)
36 # Generate arm_cde.h
37 clang_generate_header(-gen-arm-cde-header arm_cde.td arm_cde.h)
38- # Copy arm_neon_sve_bridge.h
39- copy_header_to_output_dir(${CMAKE_CURRENT_SOURCE_DIR}
40- arm_neon_sve_bridge.h
41- )
42 endif()
43 if(RISCV IN_LIST LLVM_TARGETS_TO_BUILD)
44 # Generate riscv_vector.h
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index d07243d..0537cbb 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -49,6 +49,7 @@ SRC_URI = "\
49 file://0037-sanitizer-Remove-include-linux-fs.h-to-resolve-fscon.patch \ 49 file://0037-sanitizer-Remove-include-linux-fs.h-to-resolve-fscon.patch \
50 file://0038-lldb-Get-rid-of-__STDC_LIMIT_MACROS-and-__STDC_CONST.patch \ 50 file://0038-lldb-Get-rid-of-__STDC_LIMIT_MACROS-and-__STDC_CONST.patch \
51 file://0039-lldb-Fix-error-non-const-lvalue.-caused-by-SWIG-4.1..patch \ 51 file://0039-lldb-Fix-error-non-const-lvalue.-caused-by-SWIG-4.1..patch \
52 file://0040-Install-arm_neon_sve_bridge.h.patch \
52 " 53 "
53# Fallback to no-PIE if not set 54# Fallback to no-PIE if not set
54GCCPIE ??= "" 55GCCPIE ??= ""