summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/include-what-you-use/include-what-you-use_0.22.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/include-what-you-use/include-what-you-use_0.22.bb b/recipes-devtools/include-what-you-use/include-what-you-use_0.22.bb
new file mode 100644
index 0000000..c2a4009
--- /dev/null
+++ b/recipes-devtools/include-what-you-use/include-what-you-use_0.22.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Include What You Use (IWYU) - Clang based checker for C/C++ header includes"
2DESCRIPTION = "For every symbol (type, function, variable, or macro) that you \
3 use in foo.cc (or foo.cpp), either foo.cc or foo.h should \
4 include a .h file that exports the declaration of that symbol."
5HOMEPAGE = "https://include-what-you-use.org"
6BUGTRACKER = "https://github.com/include-what-you-use/include-what-you-use/issues"
7LICENSE = "NCSA"
8LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=59d01ad98720f3c50d6a8a0ef3108c88 \
9 file://iwyu-check-license-header.py;md5=7bdb749831163fbe9232b3cb7186116f"
10
11DEPENDS = "clang"
12
13SRC_URI = "git://github.com/include-what-you-use/include-what-you-use.git;protocol=https;branch=clang_18"
14SRCREV = "377eaef70cdda47368939f4d9beabfabe3f628f0"
15
16S = "${WORKDIR}/git"
17
18inherit cmake python3native
19
20FILES:${PN} += "${datadir}/${BPN}"
21
22BBCLASSEXTEND = "nativesdk"