summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/clang/common.inc2
-rw-r--r--recipes-devtools/clang/compiler-rt-sanitizers_git.bb2
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb2
-rw-r--r--recipes-devtools/clang/libclc_git.bb2
-rw-r--r--recipes-devtools/clang/libcxx_git.bb2
-rw-r--r--recipes-devtools/clang/openmp_git.bb2
6 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index 4d70528..582820d 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -64,3 +64,5 @@ B ?= "${WORKDIR}/llvm-project-source-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
64# The real WORKDIR location isn't a dependency for the shared workdir. 64# The real WORKDIR location isn't a dependency for the shared workdir.
65src_patches[vardepsexclude] = "WORKDIR" 65src_patches[vardepsexclude] = "WORKDIR"
66should_apply[vardepsexclude] += "PN" 66should_apply[vardepsexclude] += "PN"
67
68BPN = "clang"
diff --git a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
index b42c709..1cee81b 100644
--- a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
+++ b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
@@ -10,6 +10,8 @@ SECTION = "base"
10require clang.inc 10require clang.inc
11require common-source.inc 11require common-source.inc
12 12
13BPN = "compiler-rt-sanitizers"
14
13inherit cmake pkgconfig python3native 15inherit cmake pkgconfig python3native
14 16
15 17
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 7bc81af..f88e4a2 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -12,6 +12,8 @@ SECTION = "base"
12require clang.inc 12require clang.inc
13require common-source.inc 13require common-source.inc
14 14
15BPN = "compiler-rt"
16
15inherit cmake cmake-native pkgconfig python3native 17inherit cmake cmake-native pkgconfig python3native
16 18
17 19
diff --git a/recipes-devtools/clang/libclc_git.bb b/recipes-devtools/clang/libclc_git.bb
index 0d43133..1e2f837 100644
--- a/recipes-devtools/clang/libclc_git.bb
+++ b/recipes-devtools/clang/libclc_git.bb
@@ -5,6 +5,8 @@ SECTION = "libs"
5require clang.inc 5require clang.inc
6require common-source.inc 6require common-source.inc
7 7
8BPN = "libclc"
9
8TOOLCHAIN = "clang" 10TOOLCHAIN = "clang"
9 11
10LIC_FILES_CHKSUM = "file://libclc/LICENSE.TXT;md5=7cc795f6cbb2d801d84336b83c8017db" 12LIC_FILES_CHKSUM = "file://libclc/LICENSE.TXT;md5=7cc795f6cbb2d801d84336b83c8017db"
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 816d037..85c467c 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -10,6 +10,8 @@ require common-source.inc
10 10
11inherit cmake cmake-native python3native 11inherit cmake cmake-native python3native
12 12
13BPN = "libcxx"
14
13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "unwind unwind-shared", "", d)}" 15PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "unwind unwind-shared", "", d)}"
14PACKAGECONFIG:append:armv5 = " no-atomics" 16PACKAGECONFIG:append:armv5 = " no-atomics"
15PACKAGECONFIG:remove:class-native = "compiler-rt" 17PACKAGECONFIG:remove:class-native = "compiler-rt"
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index 549df0e..398479b 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -8,6 +8,8 @@ SECTION = "libs"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11BPN = "openmp"
12
11TOOLCHAIN = "clang" 13TOOLCHAIN = "clang"
12 14
13LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" 15LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79"