diff options
-rw-r--r-- | classes/clang.bbclass | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 6 | ||||
-rw-r--r-- | recipes-support/libunwind/libunwind_%.bbappend | 2 |
3 files changed, 5 insertions, 5 deletions
diff --git a/classes/clang.bbclass b/classes/clang.bbclass index 920150a..1c981d1 100644 --- a/classes/clang.bbclass +++ b/classes/clang.bbclass | |||
@@ -109,7 +109,7 @@ def clang_base_deps(d): | |||
109 | return "" | 109 | return "" |
110 | 110 | ||
111 | BASE_DEFAULT_DEPS:toolchain-clang:class-target = "${@clang_base_deps(d)}" | 111 | BASE_DEFAULT_DEPS:toolchain-clang:class-target = "${@clang_base_deps(d)}" |
112 | BASE_DEFAULT_DEPS:append:class-native:toolchain-clang_runtime-llvm = " libcxx-native compiler-rt-native" | 112 | BASE_DEFAULT_DEPS:append:class-native:toolchain-clang:runtime-llvm = " libcxx-native compiler-rt-native" |
113 | 113 | ||
114 | cmake_do_generate_toolchain_file:append:toolchain-clang () { | 114 | cmake_do_generate_toolchain_file:append:toolchain-clang () { |
115 | cat >> ${WORKDIR}/toolchain.cmake <<EOF | 115 | cat >> ${WORKDIR}/toolchain.cmake <<EOF |
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index 9ee3d34..4ce6814 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -85,7 +85,7 @@ CXXFLAGS:append:armv5 = " -mfpu=vfp2" | |||
85 | 85 | ||
86 | ALLOW_EMPTY:${PN} = "1" | 86 | ALLOW_EMPTY:${PN} = "1" |
87 | 87 | ||
88 | PROVIDES:append_runtime-llvm = " libunwind" | 88 | PROVIDES:append:runtime-llvm = " libunwind" |
89 | 89 | ||
90 | do_install:append() { | 90 | do_install:append() { |
91 | if ${@bb.utils.contains("RUNTIME", "llvm", "true", "false", d)} | 91 | if ${@bb.utils.contains("RUNTIME", "llvm", "true", "false", d)} |
@@ -97,8 +97,8 @@ do_install:append() { | |||
97 | fi | 97 | fi |
98 | } | 98 | } |
99 | 99 | ||
100 | PACKAGES:append_runtime-llvm = " libunwind" | 100 | PACKAGES:append:runtime-llvm = " libunwind" |
101 | FILES:libunwind_runtime-llvm = "${libdir}/libunwind.so.*" | 101 | FILES:libunwind:runtime-llvm = "${libdir}/libunwind.so.*" |
102 | 102 | ||
103 | BBCLASSEXTEND = "native nativesdk" | 103 | BBCLASSEXTEND = "native nativesdk" |
104 | TOOLCHAIN:forcevariable = "clang" | 104 | TOOLCHAIN:forcevariable = "clang" |
diff --git a/recipes-support/libunwind/libunwind_%.bbappend b/recipes-support/libunwind/libunwind_%.bbappend index 7dee3e8..51c3cee 100644 --- a/recipes-support/libunwind/libunwind_%.bbappend +++ b/recipes-support/libunwind/libunwind_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | COMPATIBLE_HOST_runtime-llvm = "null" | 3 | COMPATIBLE_HOST:runtime-llvm = "null" |