diff options
-rw-r--r-- | classes/clang.bbclass | 8 | ||||
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 7 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 12 | ||||
-rw-r--r-- | recipes-devtools/clang/llvm-libunwind.bb | 6 |
4 files changed, 9 insertions, 24 deletions
diff --git a/classes/clang.bbclass b/classes/clang.bbclass index 58fe6b6..6d99b45 100644 --- a/classes/clang.bbclass +++ b/classes/clang.bbclass | |||
@@ -68,6 +68,8 @@ def clang_dep_prepend(d): | |||
68 | ret += " compiler-rt " | 68 | ret += " compiler-rt " |
69 | else: | 69 | else: |
70 | ret += " libgcc " | 70 | ret += " libgcc " |
71 | if (d.getVar('COMPILER_RT').find('--unwindlib=libunwind') != -1): | ||
72 | ret += " llvm-libunwind " | ||
71 | if (d.getVar('LIBCPLUSPLUS').find('--stdlib=libc++') != -1): | 73 | if (d.getVar('LIBCPLUSPLUS').find('--stdlib=libc++') != -1): |
72 | ret += " libcxx " | 74 | ret += " libcxx " |
73 | else: | 75 | else: |
@@ -76,9 +78,3 @@ def clang_dep_prepend(d): | |||
76 | return "" | 78 | return "" |
77 | 79 | ||
78 | BASE_DEFAULT_DEPS_toolchain-clang_class-target = "${@clang_dep_prepend(d)}" | 80 | BASE_DEFAULT_DEPS_toolchain-clang_class-target = "${@clang_dep_prepend(d)}" |
79 | |||
80 | PREFERRED_PROVIDER_libunwind_toolchain-clang = "llvm-libunwind" | ||
81 | PREFERRED_PROVIDER_libunwind ?= "libunwind" | ||
82 | PREFERRED_PROVIDER_libunwind_powerpc = "libunwind" | ||
83 | PREFERRED_PROVIDER_libunwind_riscv32 = "libunwind" | ||
84 | PREFERRED_PROVIDER_libunwind_riscv64 = "libunwind" | ||
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index d6ce083..c24329c 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -13,11 +13,10 @@ inherit cmake pkgconfig pythonnative | |||
13 | 13 | ||
14 | LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a" | 14 | LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a" |
15 | 15 | ||
16 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx" | 16 | LIBCPLUSPLUS = "" |
17 | DEPENDS_append_toolchain-clang_class-target = " virtual/${TARGET_PREFIX}compilerlibs" | 17 | COMPILER_RT = "" |
18 | TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++" | ||
19 | TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++" | ||
20 | TUNE_CCARGS_remove = "-no-integrated-as" | 18 | TUNE_CCARGS_remove = "-no-integrated-as" |
19 | |||
21 | DEPENDS += "ninja-native" | 20 | DEPENDS += "ninja-native" |
22 | DEPENDS_append_class-nativesdk = " clang-native" | 21 | DEPENDS_append_class-nativesdk = " clang-native" |
23 | 22 | ||
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index c12831a..6d94ac4 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -10,17 +10,9 @@ require common-source.inc | |||
10 | 10 | ||
11 | inherit cmake pythonnative | 11 | inherit cmake pythonnative |
12 | 12 | ||
13 | DEPENDS += "ninja-native llvm-libunwind" | 13 | DEPENDS += "ninja-native" |
14 | 14 | ||
15 | DEPENDS_remove_powerpc = "llvm-libunwind" | 15 | LIBCPLUSPLUS = "" |
16 | DEPENDS_remove_riscv32 = "llvm-libunwind" | ||
17 | DEPENDS_remove_riscv64 = "llvm-libunwind" | ||
18 | |||
19 | BASEDEPENDS_remove_toolchain-clang = "libcxx" | ||
20 | DEPENDS_append_toolchain-clang = " virtual/${TARGET_PREFIX}compilerlibs" | ||
21 | |||
22 | TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++" | ||
23 | TUNE_CCARGS_remove_toolchain-clang = "--stdlib=libc++" | ||
24 | 16 | ||
25 | LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ | 17 | LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ |
26 | file://libcxxabi/LICENSE.TXT;md5=7b9334635b542c56868400a46b272b1e \ | 18 | file://libcxxabi/LICENSE.TXT;md5=7b9334635b542c56868400a46b272b1e \ |
diff --git a/recipes-devtools/clang/llvm-libunwind.bb b/recipes-devtools/clang/llvm-libunwind.bb index eb46e11..1bcad96 100644 --- a/recipes-devtools/clang/llvm-libunwind.bb +++ b/recipes-devtools/clang/llvm-libunwind.bb | |||
@@ -13,11 +13,9 @@ inherit cmake pythonnative | |||
13 | PROVIDES += "libunwind" | 13 | PROVIDES += "libunwind" |
14 | 14 | ||
15 | DEPENDS += "ninja-native" | 15 | DEPENDS += "ninja-native" |
16 | BASEDEPENDS_remove_toolchain-clang = "libcxx" | ||
17 | DEPENDS_append_toolchain-clang = " virtual/${TARGET_PREFIX}compilerlibs" | ||
18 | 16 | ||
19 | TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++" | 17 | LIBCPLUSPLUS = "" |
20 | TUNE_CCARGS_remove_toolchain-clang = "--unwindlib=libunwind --stdlib=libc++" | 18 | UNWINDLIB = "" |
21 | 19 | ||
22 | COMPATIBLE_HOST_powerpc = "null" | 20 | COMPATIBLE_HOST_powerpc = "null" |
23 | COMPATIBLE_HOST_riscv32 = "null" | 21 | COMPATIBLE_HOST_riscv32 = "null" |