diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb new file mode 100644 index 0000000..addd2c5 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SUMMARY = "bpftrace" | ||
2 | HOMEPAGE = "https://github.com/iovisor/bpftrace" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
5 | |||
6 | DEPENDS += "bison-native \ | ||
7 | flex-native \ | ||
8 | gzip-native \ | ||
9 | elfutils \ | ||
10 | bcc \ | ||
11 | systemtap \ | ||
12 | libcereal \ | ||
13 | libbpf \ | ||
14 | " | ||
15 | DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'pahole-native llvm-native', '', d)}" | ||
16 | |||
17 | RDEPENDS:${PN} += "bash python3 xz" | ||
18 | |||
19 | PV .= "+git" | ||
20 | |||
21 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master;protocol=https \ | ||
22 | file://run-ptest \ | ||
23 | file://0001-cmake-Bump-max-LLVM-version-to-19.patch \ | ||
24 | " | ||
25 | SRCREV = "b2e255870ba010d4a7e4852bffcf1c567b016fd0" | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | inherit cmake ptest | ||
30 | |||
31 | PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" | ||
32 | |||
33 | PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native" | ||
34 | |||
35 | do_install_ptest() { | ||
36 | if [ -e ${B}/tests/bpftrace_test ]; then | ||
37 | install -Dm 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests/bpftrace_test | ||
38 | cp -rf ${B}/tests/runtime ${D}${PTEST_PATH}/tests | ||
39 | cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests | ||
40 | fi | ||
41 | } | ||
42 | |||
43 | EXTRA_OECMAKE = " \ | ||
44 | -DCMAKE_ENABLE_EXPORTS=1 \ | ||
45 | -DCMAKE_BUILD_TYPE=Release \ | ||
46 | -DUSE_SYSTEM_BPF_BCC=ON \ | ||
47 | -DENABLE_MAN=OFF \ | ||
48 | " | ||
49 | |||
50 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" | ||
51 | COMPATIBLE_HOST:libc-musl = "null" | ||
52 | |||
53 | INHIBIT_PACKAGE_STRIP_FILES += "\ | ||
54 | ${PKGD}${PTEST_PATH}/tests/testprogs/uprobe_test \ | ||
55 | " | ||