diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer')
3 files changed, 12 insertions, 12 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb index 325a6ee..43e828b 100644 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb +++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb | |||
@@ -13,10 +13,10 @@ DEPENDS += "bison-native \ | |||
13 | " | 13 | " |
14 | 14 | ||
15 | LUAJIT ?= "luajit" | 15 | LUAJIT ?= "luajit" |
16 | LUAJIT_powerpc64le = "" | 16 | LUAJIT:powerpc64le = "" |
17 | LUAJIT_powerpc64 = "" | 17 | LUAJIT:powerpc64 = "" |
18 | 18 | ||
19 | RDEPENDS_${PN} += "bash python3 python3-core python3-setuptools xz" | 19 | RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz" |
20 | 20 | ||
21 | SRC_URI = "gitsm://github.com/iovisor/bcc \ | 21 | SRC_URI = "gitsm://github.com/iovisor/bcc \ |
22 | file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ | 22 | file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ |
@@ -32,7 +32,7 @@ PV .= "+git${SRCPV}" | |||
32 | S = "${WORKDIR}/git" | 32 | S = "${WORKDIR}/git" |
33 | 33 | ||
34 | PACKAGECONFIG ??= "examples" | 34 | PACKAGECONFIG ??= "examples" |
35 | PACKAGECONFIG_remove_libc-musl = "examples" | 35 | PACKAGECONFIG:remove:libc-musl = "examples" |
36 | 36 | ||
37 | PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF," | 37 | PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF," |
38 | PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," | 38 | PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," |
@@ -45,12 +45,12 @@ EXTRA_OECMAKE = " \ | |||
45 | -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ | 45 | -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ |
46 | " | 46 | " |
47 | 47 | ||
48 | do_install_append() { | 48 | do_install:append() { |
49 | sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \ | 49 | sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \ |
50 | -i $(find ${D}${datadir}/${PN} -type f) | 50 | -i $(find ${D}${datadir}/${PN} -type f) |
51 | } | 51 | } |
52 | 52 | ||
53 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" | 53 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
54 | FILES_${PN}-doc += "${datadir}/${PN}/man" | 54 | FILES:${PN}-doc += "${datadir}/${PN}/man" |
55 | 55 | ||
56 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" | 56 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" |
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb index d6ab0ce..9f67d94 100644 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb +++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.11.4.bb | |||
@@ -11,7 +11,7 @@ DEPENDS += "bison-native \ | |||
11 | " | 11 | " |
12 | 12 | ||
13 | PV .= "+git${SRCREV}" | 13 | PV .= "+git${SRCREV}" |
14 | RDEPENDS_${PN} += "bash python3 xz" | 14 | RDEPENDS:${PN} += "bash python3 xz" |
15 | 15 | ||
16 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ | 16 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ |
17 | file://0001-bpforc.h-Include-optional-header.patch \ | 17 | file://0001-bpforc.h-Include-optional-header.patch \ |
@@ -29,4 +29,4 @@ EXTRA_OECMAKE = " \ | |||
29 | " | 29 | " |
30 | 30 | ||
31 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" | 31 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" |
32 | COMPATIBLE_HOST_libc-musl = "null" | 32 | COMPATIBLE_HOST:libc-musl = "null" |
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend b/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend index a1d4585..580d98b 100644 --- a/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend +++ b/dynamic-layers/openembedded-layer/recipes-kernel/kernel-selftest/kernel-selftest.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | DEPENDS_append = " clang-native" | 1 | DEPENDS:append = " clang-native" |
2 | DEPENDS_remove = "llvm-native" | 2 | DEPENDS:remove = "llvm-native" |
3 | 3 | ||
4 | EXCLUDE_FROM_WORLD_forcevariable = "" | 4 | EXCLUDE_FROM_WORLD:forcevariable = "" |