diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer')
2 files changed, 1 insertions, 51 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0002-ast-Add-missing-standard-header-includes.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0002-ast-Add-missing-standard-header-includes.patch deleted file mode 100644 index 2d1d0ac..0000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0002-ast-Add-missing-standard-header-includes.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 891071a52e2d5e62634bd6cff249f0d7346e66fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 6 Aug 2021 20:14:06 -0700 | ||
4 | Subject: [PATCH 2/2] ast: Add missing standard header includes | ||
5 | |||
6 | This fixes build when using libc++ from clang 13 | ||
7 | Fixes | ||
8 | src/bpforc.h:40:10: error: no template named 'unordered_map' in nam | ||
9 | espace 'std' | ||
10 | | std::unordered_map<std::string, std::tuple<uint8_t *, uintptr_t>>; | ||
11 | |||
12 | src/ast/vtable.h:76:30: error: implicit instantiation of undefined | ||
13 | template 'std::basic_string<char>' | ||
14 | | throw std::runtime_error(std::string("Unknown node: ") + typeid(n).name()); | ||
15 | | ^ | ||
16 | |||
17 | Upstream-Status: Submitted [https://github.com/iovisor/bpftrace/pull/1962] | ||
18 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
19 | --- | ||
20 | src/ast/bpforc/bpforc.h | 1 + | ||
21 | src/ast/vtable.h | 1 + | ||
22 | 2 files changed, 2 insertions(+) | ||
23 | |||
24 | diff --git a/src/ast/bpforc/bpforc.h b/src/ast/bpforc/bpforc.h | ||
25 | index de0ed0c0..1b929dfd 100644 | ||
26 | --- a/src/ast/bpforc/bpforc.h | ||
27 | +++ b/src/ast/bpforc/bpforc.h | ||
28 | @@ -23,6 +23,7 @@ | ||
29 | #endif | ||
30 | |||
31 | #include <optional> | ||
32 | +#include <unordered_map> | ||
33 | |||
34 | namespace bpftrace { | ||
35 | |||
36 | diff --git a/src/ast/vtable.h b/src/ast/vtable.h | ||
37 | index 49e0f512..b89e6979 100644 | ||
38 | --- a/src/ast/vtable.h | ||
39 | +++ b/src/ast/vtable.h | ||
40 | @@ -4,6 +4,7 @@ | ||
41 | #include <typeindex> | ||
42 | #include <typeinfo> | ||
43 | #include <unordered_map> | ||
44 | +#include <string> | ||
45 | |||
46 | namespace bpftrace { | ||
47 | namespace ast { | ||
48 | -- | ||
49 | 2.32.0 | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb index 006ca21..952a66f 100644 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb +++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.13.0.bb | |||
@@ -18,9 +18,8 @@ RDEPENDS:${PN} += "bash python3 xz" | |||
18 | 18 | ||
19 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ | 19 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master \ |
20 | file://0001-support-clang-upto-version-13.patch \ | 20 | file://0001-support-clang-upto-version-13.patch \ |
21 | file://0002-ast-Add-missing-standard-header-includes.patch \ | ||
22 | " | 21 | " |
23 | SRCREV = "24e1ca2f55591d2d284e0e80b77a22efd790e942" | 22 | SRCREV = "283fe526dfc262fdecddec4beb921835ea0cc89e" |
24 | 23 | ||
25 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
26 | 25 | ||