diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer')
3 files changed, 0 insertions, 130 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Bump-max-LLVM-version-to-19.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Bump-max-LLVM-version-to-19.patch deleted file mode 100644 index 88dc60b..0000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-cmake-Bump-max-LLVM-version-to-19.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | From 16186113346c268a0bb45424ba1c41768b7e94cf Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 16 Feb 2024 10:14:41 -0800 | ||
4 | Subject: [PATCH] cmake: Bump max LLVM version to 19 | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/bpftrace/bpftrace/pull/3433] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | CMakeLists.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | Index: git/CMakeLists.txt | ||
13 | =================================================================== | ||
14 | --- git.orig/CMakeLists.txt | ||
15 | +++ git/CMakeLists.txt | ||
16 | @@ -152,7 +152,7 @@ else() | ||
17 | endif() | ||
18 | |||
19 | set(MIN_LLVM_MAJOR 13) | ||
20 | -set(MAX_LLVM_MAJOR 18) | ||
21 | +set(MAX_LLVM_MAJOR 19) | ||
22 | |||
23 | if((${LLVM_VERSION_MAJOR} VERSION_LESS ${MIN_LLVM_MAJOR}) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER ${MAX_LLVM_MAJOR})) | ||
24 | message(SEND_ERROR "Unsupported LLVM version found via ${LLVM_INCLUDE_DIRS}: ${LLVM_VERSION_MAJOR}") | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/run-ptest b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/run-ptest deleted file mode 100644 index 63d65e2..0000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/run-ptest +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # The whole test suite may take up to 40 minutes to run, so setting -t 2400 | ||
4 | # parameter in ptest-runner is necessary to not kill it before completion | ||
5 | |||
6 | cd tests || exit 1 | ||
7 | export BPFTRACE_RUNTIME_TEST_EXECUTABLE=/usr/bin/bpftrace | ||
8 | export BPFTRACE_AOT_RUNTIME_TEST_EXECUTABLE=/usr/bin/bpftrace-aotrt | ||
9 | |||
10 | PASS_CNT=0 | ||
11 | FAIL_CNT=0 | ||
12 | SKIP_CNT=0 | ||
13 | FAILED="" | ||
14 | |||
15 | print_test_result() { | ||
16 | if [ $? -eq 0 ]; then | ||
17 | echo "PASS: $1" | ||
18 | PASS_CNT=$((PASS_CNT + 1)) | ||
19 | else | ||
20 | echo "FAIL: $1" | ||
21 | FAIL_CNT=$((FAIL_CNT + 1)) | ||
22 | FAILED="${FAILED:+$FAILED }$1;" | ||
23 | fi | ||
24 | } | ||
25 | |||
26 | IFS=$(printf '\n\t') | ||
27 | # Start unit tests | ||
28 | for test_name in $(./bpftrace_test --gtest_list_tests | grep -v "^ "); do | ||
29 | ./bpftrace_test --gtest_filter="${test_name}*" > /dev/null 2>&1 | ||
30 | print_test_result "unit:$test_name" | ||
31 | done | ||
32 | |||
33 | # Start runtime tests | ||
34 | for test_name in $(ls runtime); do | ||
35 | # Ignore test cases that hang the suite forever (bpftrace v0.16.0) | ||
36 | if [ "$test_name" = "signals" ] || [ "$test_name" = "watchpoint" ]; then | ||
37 | echo "SKIP: runtime:$test_name" | ||
38 | SKIP_CNT=$((SKIP_CNT + 1)) | ||
39 | continue | ||
40 | fi | ||
41 | python3 runtime/engine/main.py --filter="${test_name}.*" > /dev/null 2>&1 | ||
42 | print_test_result "runtime:$test_name" | ||
43 | done | ||
44 | unset IFS | ||
45 | |||
46 | echo "#### bpftrace tests summary ####" | ||
47 | echo "# TOTAL: $((PASS_CNT + FAIL_CNT + SKIP_CNT))" | ||
48 | echo "# PASS: $PASS_CNT" | ||
49 | echo "# FAIL: $FAIL_CNT ($FAILED)" | ||
50 | echo "# SKIP: $SKIP_CNT" | ||
51 | echo "################################" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb deleted file mode 100644 index addd2c5..0000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.21.2.bb +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | SUMMARY = "bpftrace" | ||
2 | HOMEPAGE = "https://github.com/iovisor/bpftrace" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
5 | |||
6 | DEPENDS += "bison-native \ | ||
7 | flex-native \ | ||
8 | gzip-native \ | ||
9 | elfutils \ | ||
10 | bcc \ | ||
11 | systemtap \ | ||
12 | libcereal \ | ||
13 | libbpf \ | ||
14 | " | ||
15 | DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'pahole-native llvm-native', '', d)}" | ||
16 | |||
17 | RDEPENDS:${PN} += "bash python3 xz" | ||
18 | |||
19 | PV .= "+git" | ||
20 | |||
21 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=master;protocol=https \ | ||
22 | file://run-ptest \ | ||
23 | file://0001-cmake-Bump-max-LLVM-version-to-19.patch \ | ||
24 | " | ||
25 | SRCREV = "b2e255870ba010d4a7e4852bffcf1c567b016fd0" | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | inherit cmake ptest | ||
30 | |||
31 | PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" | ||
32 | |||
33 | PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native" | ||
34 | |||
35 | do_install_ptest() { | ||
36 | if [ -e ${B}/tests/bpftrace_test ]; then | ||
37 | install -Dm 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests/bpftrace_test | ||
38 | cp -rf ${B}/tests/runtime ${D}${PTEST_PATH}/tests | ||
39 | cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests | ||
40 | fi | ||
41 | } | ||
42 | |||
43 | EXTRA_OECMAKE = " \ | ||
44 | -DCMAKE_ENABLE_EXPORTS=1 \ | ||
45 | -DCMAKE_BUILD_TYPE=Release \ | ||
46 | -DUSE_SYSTEM_BPF_BCC=ON \ | ||
47 | -DENABLE_MAN=OFF \ | ||
48 | " | ||
49 | |||
50 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" | ||
51 | COMPATIBLE_HOST:libc-musl = "null" | ||
52 | |||
53 | INHIBIT_PACKAGE_STRIP_FILES += "\ | ||
54 | ${PKGD}${PTEST_PATH}/tests/testprogs/uprobe_test \ | ||
55 | " | ||