summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/musl/musl_%.bbappend7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend
index c99c4be..8732a4f 100644
--- a/recipes-core/musl/musl_%.bbappend
+++ b/recipes-core/musl/musl_%.bbappend
@@ -1,10 +1,5 @@
1DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}" 1DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}"
2DEPENDS_remove_toolchain-clang = "virtual/${TARGET_PREFIX}gcc"
2TOOLCHAIN_x86-x32 = "gcc" 3TOOLCHAIN_x86-x32 = "gcc"
3TOOLCHAIN_riscv64 = "gcc" 4TOOLCHAIN_riscv64 = "gcc"
4TOOLCHAIN_powerpc64 = "gcc" 5TOOLCHAIN_powerpc64 = "gcc"
5
6# workaround until https://bugs.llvm.org/show_bug.cgi?id=44384
7# is fixed
8do_configure_prepend_toolchain-clang () {
9 sed -i -e '/frounding-math/d' ${S}/configure
10}